0

I have a fresh install of Linux Mint 18.3 (System setup: dual-boot with Windows 10)

I set up 4 accounts:

user_1
user_2
user_3
user_4

I did not write the passwords down, woke up the next morning and couldn't remember any of them.

I attempted to change the passwords for all four users as follows:

(1) Booted my system and when the Grub menu appeared, 
    I made sure my Linux Mint 18.3 OS was highlighted,
    I pressed e (for edit).
(2) Arrowed down to the line that starts with "linux"
    It looks like this: linux /boot/vmlinuz-3.16.0-38-generic, 
    root=UUID=b1bde976-50e2-4c32-a760-17b091b4202f ro quiet splash 
    $vt_handoff
(3) At the end of that line I deleted the words,
     "quiet splash $vt_handoff" if that is there, and put: rw init=/bin/bash
(4) I then pressed F10 to boot. 
     This resulted as a boot into a root shell.
     I did an ls /home and the system outputted the following:
     user_2
     user_3
(5) I entered a new password for both these users as follows:
    passwd user_1 (and when prompted twice for the password, 
    I entered the new password both times)
(6) I then entered the following command: sync
(7) Next I entered the following command: reboot -f

Note: I also did the same as step (4) step (5), step (6) and step (7) for root

At this point I successfully achieved in changing the password for user_1, user_2 and root.

However, I am still unable to login to user_1 and user_4 at the login screen, as I still do not know the correct passwords for these users.

My Question(s):

(a) How do I change the passwords for user_1 and user_4?
    I assume both are administrative users, especially since it is,
    my belief that the first user created after a fresh install is,
    an administrative account by default.

(b) Why when I log in as user_2 or user_3 and do an ls /home does it only show me, 
    the user accounts for user_2 and user_3.

(c) In general, should I only have one admin account on my system?

(d) Does an administrator account have the same privileges as root after,
    (su "ing" subsequent to logging, into user_2 and user_3)  
  • You say you changed user_1's password but in the end ask how to change it. I'm confused. Why wouldn't your procedure work for all the users? It looks right to me. Unless you talk sudo and such, there is only one true administrator account on every linux machine: root. – confetti Aug 12 '18 at 7:50
  • @confetti Yes, I changed the passwords for all users using the process described above. That enabled me to log into user_2 and user_3's account using their new passwords. However, I am still unable to log in to user_1 and user_4's account, therefore I am seeking a way to change these passwords or a reason for why the passwords for these accounts did not change like the passwords for user_2 and user_3, even though the same process was used? I don't know if it makes a difference or not but the command shell field in /etc/passwd is :/bin/bash for user_2 & user_3 but not user_1 and user_4? – MarkMark Aug 12 '18 at 21:36
1
  • The sequence you described is the correct way to reset a password if you lost access to root on the machine. Linux doesn't have a concept of an administrative user besides root, unless you talk about sudo privileges.
  • Home directories don't need to be in /home, it is just often done this way. Look at /etc/passwd for the home directories of these users.
  • You can have as many accounts as you want with sudo privileges fitting your needs.
  • su to user_2 or user_3 only gives the rights of that user, not the rights of root.

Edit

Some additional observations based on the comments and the text in the other answer:

If I select user_1 OR user_4 and enter the same password the system will act as if it is about to login (screen goes blank for 1 or 2 seconds) then returns to the login screen. If I enter the wrong password I will immediately see the error "Incorrect password, please try again".

This indicates that the password is correct and there is something wrong. In general in such cases it is a good idea to try a known wrong password and see whether the reaction of the system is different.

While it is possible to have home directories outside of /home, in your case not only the passwords but also two of the home directories were lost. This was the reason why the login aborted. A message to that effect should have been written to some logfile.

  • Based on your answer and this; readhttps://unix.stackexchange.com/questions/291454/difference-between-sudo-user-and-root-user. It would seem that root is the only admin user for a Linux OS, but any user can access root privileges once that user is listed in the sudoers file. I checked out /etc/passwd and discovered that the home directories for user_2 and user_3 are /home/user_x and the home directories of user_1 and user_4 are /home/user_x. Interestingly the command shell field for both accounts I can log into is /bin/bash but for the accounts I can't log into it is blank, why? – MarkMark Aug 12 '18 at 21:39
  • Also, when logged in as either user_2 or user_3 I can: su - user_1 OR su - user_4, the system will accept the new passwd, set using the process outlined in the question and log me into the respective user account (I verify using whoami), but will inform me of the following; "No directory, logging in with HOME=/" . – MarkMark Aug 12 '18 at 22:04
  • However, if I restart the system, when I get to the login screen, where I can choose to login as user_1, user_2, user_3 or user_4, if I select user_1 OR user_4 and enter the same password the system will act as if it is about to login (screen goes blank for 1 or 2 seconds) then returns to the login screen. If I enter the wrong password I will immediately see the error "Incorrect password, please try again". I am not sure of the relevance of this? – MarkMark Aug 12 '18 at 22:06
0

The problem:

Initially I followed the password reset process outlined in the question, this worked for user_2 and user_3 (i.e I could login using the new password), however I was still unable to log in to the the user_1 and user_4 accounts.

I solved this using the following process:

(1) I logged into user_2 using the new password.

(2) Opened a terminal and entered the following command:

su - user_1 

Note: When prompted for the password I used the new password, as assigned to user_1 using the process outlined in the question, and it worked. However the system displayed the following text:

No directory, logging in with HOME=/

(3) I then entered the following command:

mkdir /home/user_1

(4) Following on from this I accessed root privileges using the following command:

su 

Note: Password was the same as set during the process outlined in the question.

(5) Then I did the following:

chown user_1:user_1 /home/user_1

(6) I then closed the terminal session and logged out of user_2

(7) Finally to verify when I ended up back at the main login screen I selected the user_1 account and was able to login using the process outlined in the question.

Note: I did the same for user_4.

I would like to thank @RalfFriedl and @confetti for their input

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.