-1

This question already has an answer here:

I watched a few tutorials for wireless hacking and everywhere they have network interfaces called wlan0, eth0, ... but my interface is called wlp4s0. Does that mean, I have to use another tutorial, because simply replacing wlan0 with wlp4s0 does not seem to work?

oussema@super-computer:~$ sudo airmon-ng start wlp4s0


Found 2 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!

PID     Name
2463    avahi-daemon
2470    avahi-daemon


Interface   Chipset     Driver

wlp4s0      Broadcom    wl - [phy0]mon0: ERREUR en récupérant les signaux de l'interface: Aucun périphérique de ce type (translated from french to english: ERROR when retrieving the signals from the interface: No device of this type)

            (monitor mode enabled on mon0)

marked as duplicate by jasonwryan, Jeff Schaller, Rui F Ribeiro, Thomas, schily Aug 12 '18 at 13:20

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    This is supposed to be the new best thing in Linux: "predictable" naming. It only fails if you add or remove PCI devices and your interfaces shift, but who cares in the ivory tower? You can disable that, or create copies of your network scripts for other device numbers. – ajeh Aug 11 '18 at 21:05
2

These interface names are the so called predictable interface names by systemd. Add net.ifnames=0 to the kernel command line to disable this.

Not the answer you're looking for? Browse other questions tagged or ask your own question.