1

When trying to boot the latest live boot from Debian with the 4.17 kernel, the boot fails and kicks me to an initramfs shell. I cannot find the USB device that I am trying to boot from in /dev, which matches the messages I'm seeing.

Since it's on another system with no OS, I can't copy the whole log, but I'm seeing messages like these:

[ 7.13] xhci_hcd 0000:00:14.0 Timeout while waiting for setup device command
[12.51] xhci_hcd 0000:00:14.0 Timeout while waiting for setup device command
[12.72] usb 2-1: device not accepting address 2, error -62

There are more until 26 seconds, at one point it tries to power cycle a usb port, it finds a USB bluetooth radio... but it doesn't seem to recognize the USB device/port that the USB stick is in.

What could I do to resolve this? Ubuntu seems to work, but I would much prefer to install Debian on my system.

Edit: by happenstance I noticed that when replugging the USB device, /dev/sdb appears. I retried booting and as soon as I saw it was starting to stall (before 7 seconds ticked by), I replugged the USB stick. It now boots to a shell. Still not the graphical environment I should get, so something is still wrong. Not sure how to get this working.

  • This is the price you pay for being on the bleeding edge. I still remember missing network interfaces trying to upgrade to the latest versions in the past, so do yourself a favour and stay a couple versions behind - at least their bugs would have been fixed by now. Or fight an uphill battle to work around these bugs. Your call. – ajeh Aug 11 '18 at 17:51
  • @ajeh I tried that. A couple versions ago it didn't have support for my hardware because the hardware is from the last 6 months or so (I just bought a new, fairly high-end laptop). – Luc Aug 12 '18 at 16:30
  • You can of course try to work with the driver maintainers through kernel bugzilla, if you have time and energy. Or wait a few months or years. – ajeh Aug 13 '18 at 15:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.