4

I have Lubuntu 11.04, I start my terminal sessions with a shortcut.

The annoying thing is that the terminal windows are never maximized when I launch them, so every time I launch a terminal I must resort to using the mouse.

How do I set it so that the terminal session windows open maximized when I start them?

The Lubuntu terminal is LXTerminal.

2
  • If you would consider changing to for example xterm or urxvt then you would put such options in the .Xresources file. (There is probably a configuration file for LXTerminal as well, otherwise it is configurable with the tools that come with Ubuntu.) Aug 23, 2012 at 20:35
  • Not sure if I will help anyone, but I just tested random things and in my raspberry pi Alt + F11 toggled fullscreen and really fullscreen. I can't get out without closing it though, but it's something
    – user27221
    Aug 18, 2021 at 12:20

5 Answers 5

7

I don't have Lubuntu installed to test but maybe:

To configuration file ~/.config/openbox/lubuntu-rc.xml adding the lines below :

<!-- Option to maximize all normal window when launched-->
<application type="normal">
<maximized>true</maximized>
</application>

Removal of this was suggested as a way to STOP it from doing so here.

4
  • yeah i tried that, to no avail.
    – john-jones
    Aug 23, 2012 at 21:38
  • 4
    I just tried <application name="lxterminal"> <maximized>yes</maximized> </application> (appropriately formatted) and it worked for me. I ran openbox --reconfigure after making the change.
    – user15760
    Sep 20, 2012 at 3:48
  • It appears like the answer works for 12.04, but vasa1's comment works for 11.04.
    – john-jones
    Feb 1, 2013 at 10:49
  • 1
    but how do you indicate you only want the terminal opened maximized because of this, and nothing else?
    – john-jones
    May 15, 2014 at 16:55
2

Try gdevilspie, match lxterminal window, and auto-maximizing,

Just an example on how it works (with gnome-terminal), first hit on 'Get' and select the LXterminal,

enter image description here

And in actions, select 'maximize', save the rule. So any time you start LXterminal, it would start maximized.

Last thing you need to make sure if daemon is running at start:

enter image description here

4
  • Well it definitely seems to be in the direction. I've installed devilspie and created a rule which has actions->maximize. Then in matching i click 'window_class' and have tried 'Terminal' and 'LXTerminal'. But it doesn't work.
    – john-jones
    Aug 24, 2012 at 6:25
  • @HermannIngjaldsson don't type in anything, use the 'Get' button to get the correct value
    – daisy
    Aug 24, 2012 at 6:36
  • @HermannIngjaldsson wait, did you start devispie daemon ?
    – daisy
    Aug 24, 2012 at 6:36
  • Ok now i used the 'get' button. Still doesn't work and yeah the daemon is running.
    – john-jones
    Aug 24, 2012 at 6:55
2

hbdgaf's answer above was very close (on ubuntu 12.04), but instead of "true", you need to use "yes" to tell it to maximize.

So, inside the applications block in /home/(your username)/.config/openbox/lxde-rc.xml, add the following block and it will work:

<applications>
    <application name="lxterminal">
        <maximized>yes</maximized>
    </application>
</applications>

Similarly, if you want to minimize it, use iconic tab and set to "no". Not sure why the openbox folks used yes and no instead of true and false but they sure did!

0

In my case (Lubuntu Bionic 18.04), to get it to work directly with LXTerminal I needed to edit the name attribute to x-terminal-emulator.

<application name="x-terminal-emulator">
    <maximized>yes</maximized>
</application>

If you also want to avoid pressing F11 after each launch of lxterminal you can simply add <fullscreen>yes</fullscreen> to the config like so:

<application name="x-terminal-emulator">
    <maximized>yes</maximized>
    <fullscreen>yes</fullscreen>
</application>

If you also want to get rid of the Menu / Scroll bars then go to Edit - Preferences - Display and make sure these are checked:

  • Hide scroll bar
  • Hide menu bar

Lastly, if you would like to show the menu/scroll bar again. You would have to edit this file ~/.config/lxterminal/lxterminal.conf and these lines to your needs:

hidescrollbar=true
hidemenubar=false
-1

If your objective is to maximize the size of the terminal on your screen, without any screen area wasted on the menu bar (showing File, Edit, View, ...), then simply switch to a virtual console by pressing Alt+F1 or Ctrl+Alt+F1

Note: you can substitute any of F1 to F6 in the above key combination. F7 will take you back to the GUI

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .