0

This question already has an answer here:

I issue

$ pacman -Su
:: Starting full system upgrade...
error: duplicated database entry 'python2-cairo'
 there is nothing to do

So I have a look at /var/lib/pacman/local

$ ls /var/lib/pacman/local/ | grep cairo
cairo-1.15.12-1
cairomm-1.12.2-2
python2-cairo-1.17.0-1
python2-cairo-1.17.0-2
python-cairo-1.17.0-2

How can I:

  • See why python2-cairo-1.17.0-1 and python2-cairo-1.17.0-1 are both installed (what packages depend on them)

  • Get rid of python2-cairo-1.17.0-1

  • Fix the duplicated database entry error...

marked as duplicate by jasonwryan, Thomas, Jeff Schaller, slm Aug 11 '18 at 14:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

I hadd a look at this and tried with:

$ sudo mv /var/lib/pacman/local/python2-cairo-1.17.0-1/ ~/tmp/

Now the error is no longer appearing, but I'm not quite sure if I left anything broken behind

--

I followed @jasonwryan advice, pacman -Syu seems to wokr fine, but then I tried with

sudo pacman -Qkk | grep mismatch

and found several files under /usr/lib/python2.7/ Modification time mismatch warnings. But apart from that everything seems to be ok

  • 2
    Run a full update: -Syu and then check for issues with -Qkk. – jasonwryan Aug 11 '18 at 5:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.