2

I'm trying to install darktable from source on Fedora 27. I've installed all dependencies, but when I run cmake I got error:

-- Could NOT find LLVM (missing: LLVM_DIR)
CMake Warning at CMakeLists.txt:381 (message):
  Could not find LLVM 3.9+

What should be the content of this variable.

I've tried this:

$ whereis llvm
llvm: /usr/lib64/llvm
$ export LLVM_DIR=/usr/lib64/llvm
$ cmake -DCMAKE_INSTALL_PREFIX=/opt/darktable/ ..

but got the same error that it can't find llvm. I have llvm version 5.0.2

  • 1
    Try cmake -DLLVM_DIR=/usr/lib64/llvm .... – arrowd Aug 11 '18 at 10:54
0

Just ran into the same while trying to build darktable release-2.7.0 on fedora 29.

Was able to resolve it by installing llvm-devel

dnf install llvm-devel

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.