3

I am trying to build a generic arm kernel and then run it with QEMU but not having any success.

I downloaded linux-4.17.13.tar.xz from Kernel.org extracted it and ran the commands below to build it

make ARCH=arm CROSS_COMPILE=arm-linux-gnueabi- alldefconfig
make ARCH=arm CROSS_COMPILE=arm-linux-gnueabi- nconfig

Enabled the following options:

[*] 8250/16550 and compatible serial support
[*] Console on 8250/16550 and compatible serial port

Finally running

make ARCH=arm CROSS_COMPILE=arm-linux-gnueabi- -j2 zImage

Then I ran the command to start qemu with the kernel image

qemu-system-arm -M versatilepb -m 128M -kernel arch/arm/boot/zImage -nographic -append "console=ttyS0"

Here I see no output of any kind after presssing enter, just a newline and a hanging cursor on the terminal. What have I missed or am I doing wrong?

closed as too broad by Rui F Ribeiro, msp9011, schily, lgeorget, slm Aug 10 '18 at 13:05

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • what would help make this question more specific? – Bob R Aug 10 '18 at 23:12
  • Nobody? 5 users think its vague but none have recommendations on how to improve it. Interesting. – Bob R Aug 11 '18 at 2:52
  • Have you made any progress on that? I am having the exact same problem as you did! – perror Sep 20 '18 at 7:58
  • @perror no unfortunately I have not. – Bob R Sep 25 '18 at 5:11