1

I have record variable defined in my .muttrc , the copy var is set to yes. Messages are saved to my Sent (record) folder if I sent them interactively. If however I do it w/o opening interactive mutt session like this:

echo Message set non-interactively | mutt -s "Test noninteractively" email@addr.ess

messages go, but not kept in record

I tried -d option and compared debug log from both session, there's only obvious differences like timestamps in there.

What could be the reason, and what is more to check?

update - my .muttrc just in case some other thing matters

set imap_user = "user@server.com"                           
smtp_pass "***"
set imap_pass = $smtp_pass
set smtp_url = "smtp://user@mail.server.com:25/"           
set from = "user@server.com"                                
set realname = "Tag Wint"                                      
set folder = "imaps://mail.server.com:993"               
alternates "(user|tagwint)@server.com"
set spoolfile = "+INBOX"                                          
set postponed = "+Drafts"                                 
# set record = "+/Sent"  # <-- tried also naming this way 
set record="imaps://mail.server.com:993/Sent"
set copy = yes                                 
set save_name = yes
set force_name = yes
set header_cache = ~/.mutt/com.server.user/cache/headers                
set message_cachedir = ~/.mutt/com.server.user/cache/bodies             
set certificate_file = ~/.mutt/com.server.user/certificates             
# vim: ft=muttrc
  • I also have force_name set, and for me it works. – wurtel Aug 10 '18 at 10:00
  • Enforcement did not help :) tried also save_name. Both to yes. I suspect it has smthing to do with how record folder is named. I am going to extend my question with .muttrc – Tagwint Aug 10 '18 at 10:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.