I'm seeing an issue with zsh where a glob character within a variable is not expanding as I would expect. The following example does a better job of explaining it.

$ echo $0

$ echo $HOME/Downloads/zsh-test/*
/Users/bruce/Downloads/zsh-test/file1 /Users/bruce/Downloads/zsh-test/file2 /Users/bruce/Downloads/zsh-test/file3 /Users/bruce/Downloads/zsh-test/file4

$ file=*; echo $HOME/Downloads/zsh-test/$file
/Users/bruce/Downloads/zsh-test/file1 /Users/bruce/Downloads/zsh-test/file2 /Users/bruce/Downloads/zsh-test/file3 /Users/bruce/Downloads/zsh-test/file4

Macbook% echo $0

Macbook% echo $HOME/Downloads/zsh-test/*
/Users/bruce/Downloads/zsh-test/file1 /Users/bruce/Downloads/zsh-test/file2 /Users/bruce/Downloads/zsh-test/file3 /Users/bruce/Downloads/zsh-test/file4

Macbook% file=*; echo $HOME/Downloads/zsh-test/$file

I would have expected the last command to expand like it does in bash. Any idea what I'm doing wrong?

  • What was your current working directory when you ran each of those commands? Aug 8, 2018 at 19:49

1 Answer 1


That would be the first time I see anybody complaining about that (we more often see people complaining about it not doing word splitting upon parameter expansion).

Most people expect

echo $file

to output the content of the $file variable and are annoyed when shells like bash don't (a behaviour inherited from the Bourne shell, unfortunately not fixed by ksh and specified by POSIX for the sh interpreter), and that's causing a lot of bugs and security vulnerabilities and that's why you need to quote all the variables in those shells.

See for instance: Security implications of forgetting to quote a variable in bash/POSIX shells

I see that you're expecting that too as you're writing echo $0 and not echo "$0".

zsh has fixed that. It does neither globbing nor word splitting by default upon parameter expansion. You need to request those explicitly:

  • echo $=file: perform word splitting
  • echo $~file: perform globbing
  • echo $=~file: perform both

Or you could turn on the globsubst and shwordsplit options to get the same behaviour as in Bourne-like shells (those two options are enabled when zsh is invoked as sh for sh compatibility), but I would not recommend that unless you need zsh to interpret code written for another shell (and even in that case, it would make more sense to interpret that code in sh emulation in a local context with emulate -L sh).

Here naming your variable file in


is misleading if you intend it to be expanded upon expansion¹


would make more sense. If you want a variable holding the name of all the non-hidden files in the current directory, you'd do:




for that assignment not to fail if there's no non-hidden file in the current directory.

That is, use an array variable assignment. That (file=(*)) would work the same as in bash or ksh93, mksh or yash, except that zsh doesn't have that other misfeature of the Bourne shell whereby the pattern is left unexpanded when there's no match.

¹Note that * is a perfectly valid name for a file on Unix-like system. I take some comfort in that rm -f -- $file removes the file whose name is stored in $file even if that file is called *.

  • 1
    Learnt a lot from this answer. Thanks. I really boiled this question down for simplicity. I am actually trying to loop through files in a directory with some wildcard matching, in a script that must work in bash and zsh. I'll post that as a separate question. Aug 8, 2018 at 20:22
  • 1
  • In the file pattern example, isnt that glob expanded and assigned to file_pattern by bash? Before it ever gets expanded by $file_pattern? Aug 9, 2018 at 1:38
  • @D.BenKnoble, no. Try f=*; echo "$f" in bash. That's an assignment to a scalar variable, which can contain only one value. You'd need f=(*) as shown, that is do an array variable assignment for a variable to contain any number of values. Aug 9, 2018 at 5:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .