0

I am trying to use curl for login request automation. Here, use of cookie-jar is must. When I use --cooki-jar cjar option, it shows following error.

root@kali:~# curl --cookie-jar cjar --output /root/Desktop/Curl/ \ https://www.google.com
curl: (1) Protocol " https" not supported or disabled in libcurl 

When I did bit of googling around it, this link says that libcurl3 and here they say that need to install libssl-dev.

When I verified my system for both the libraries, in my Kali Linux box, latest versions are available. Still it is showing the error. So could someone help me to solve this issue.

System details:

root@kali:~# dpkg -s libssl-dev
Package: libssl-dev
Status: install ok installed
Priority: optional
Section: libdevel
Installed-Size: 6908
Maintainer: Debian OpenSSL Team <pkg-openssl-devel@lists.alioth.debian.org>
Architecture: amd64

Multi-Arch: same Source: openssl Version: 1.1.0g-2 Depends: libssl1.1 (= 1.1.0g-2) Recommends: libssl-doc Conflicts: libssl1.0-dev Description: Secure Sockets Layer toolkit - development files This package is part of the OpenSSL project's implementation of the SSL and TLS cryptographic protocols for secure communication over the Internet. . It contains development libraries, header files, and manpages for libssl and libcrypto. Homepage: https://www.openssl.org/

root@kali:~# dpkg -s libcurl3
Package: libcurl3
Status: install ok installed
Priority: optional
Section: libs
Installed-Size: 649
Maintainer: Alessandro Ghedini <ghedo@debian.org>
Architecture: amd64
Multi-Arch: same
Source: curl
Version: 7.57.0-1
Depends: libc6 (>= 2.17), libcomerr2 (>= 1.01), libgssapi-krb5-2 (>= 1.14+dfsg), libidn2-0 (>= 0.6), libk5crypto3 (>= 1.6.dfsg.2), libkrb5-3 (>= 1.6.dfsg.2), libldap-2.4-2 (>= 2.4.7), libnghttp2-14 (>= 1.12.0), libpsl5 (>= 0.13.0), librtmp1 (>= 2.4+20131018.git79459a2-3~), libssh2-1 (>= 1.7.0), libssl1.0.2 (>= 1.0.2d), zlib1g (>= 1:1.1.4)
Recommends: ca-certificates
Description: easy-to-use client-side URL transfer library (OpenSSL flavour)
libcurl is an easy-to-use client-side URL transfer library, supporting DICT,
FILE, FTP, FTPS, GOPHER, HTTP, HTTPS, IMAP, IMAPS, LDAP, LDAPS, POP3, POP3S,
RTMP, RTSP, SCP, SFTP, SMTP, SMTPS, TELNET and TFTP.

. libcurl supports SSL certificates, HTTP POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies, cookies, user+password authentication (Basic, Digest, NTLM, Negotiate, Kerberos), file transfer resume, http proxy tunneling and more! . libcurl is free, thread-safe, IPv6 compatible, feature rich, well supported, fast, thoroughly documented and is already used by many known, big and successful companies and numerous applications. . SSL support is provided by OpenSSL. Homepage: http://curl.haxx.se

  • what does curl --version | grep Protocols show? – Tim Kennedy Aug 8 '18 at 15:30
0

You have unexpected backslash in command and also --output should be a filename. Try this:

curl --cookie-jar cjar --output /root/Desktop/Curl/output.html https://www.google.com

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.