3

When i connect via xrdp 0.9.1-9+deb9u3 -> xorg from windows RDP client to Debian 9.5 i have this this message on Desktop

Running in software rendering mode

Cinnamon is currently running without video hardware acceleration and as a result, you may observe much higher than normal CPU usage.

There could be a problem with your drivers or some other issue. For the best experience, it is recommended that you only use this mode for troubleshooting purposes.

How avoid this problem?

  • You mean, how can you suppress the warning message? – bgvaughan Aug 13 '18 at 19:08
  • Not only supress, increase speed too – ilw Aug 15 '18 at 12:44
  • Using remote viewing software, like RDP, involves emulating a video card in software. You cannot use hardware acceleration on the remote system, which is the one with the warning message. – bgvaughan Aug 16 '18 at 20:40
1

There is an experimental GPU-enabled version of xorgxrdp (part of xrdp). Details are in https://github.com/neutrinolabs/xrdp/issues/1029, code itself https://github.com/jsorg71/xorgxrdp/tree/glamor

Look and feel looks way better in my setup, your mileage and support of graphic adapters might vary. Be ready for high CPU usage by xrdp when something is actively updating on the screen, ie watching video.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.