1

I am installing Firefox version 36.0 on Debian 9.3

Initially I install the following 3 packages:

- xvfb
- libdbus-glib-1-2
- imagemagick

I then downloaded the deb file firefox-mozilla-build_36.0-0ubuntu1_amd64.deb

And I install it then.

Once completed, I try to run Firefox but it gives me the ERROR:

vagrant@packer-debian-9:~$ firefox
XPCOMGlueLoad error for file /opt/firefox/libxul.so:
libXcomposite.so.1: cannot open shared object file: No such file or directory
Couldn't load XPCOM.

I cant seem to find what the issue here is. Is there a specal library I need to install ?

migrated from serverfault.com Aug 6 '18 at 20:51

This question came from our site for system and network administrators.

2

That deb package firefox-mozilla-build_36.0-0ubuntu1_amd64.deb you are trying to use is for Ubuntu and not Debian; it is also an oldish version of Firefox from 3 years ago. As such, it has dependencies missing.

To install Firefox in Debian Stretch do:

apt-get install firefox-esr

Package: firefox-esr (52.9.0esr-1~deb9u1)

Mozilla Firefox web browser - Extended Support Release (ESR)

Firefox ESR is a powerful, extensible web browser with support for modern web application technologies.

PS Be aware were from and how you get new packages. The repository where you found your deb file is clearly Ubuntu-oriented.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.