0

I'm printing from Ubuntu Server 16.04 using lpr -omedia=A4 -PXerox_Phaser_7400DN my_file.ps.

I'm using this OpenPrinting driver: http://www.openprinting.org/printer/Xerox/Xerox-Phaser_7400

The problem I'm facing is even as I'm creating an A4 document and setting -omedia=A4 it is printed in A3.

What can be happening?.

  • Check your printer settings through CUPS: http://localhost:631/printers/Xerox_Phaser_7400DN – waltinator Aug 6 '18 at 15:02
  • Hi @waltinator, then I can select Modify Printer or Sed Default Options, where should I go?. – leonardorame Aug 6 '18 at 18:48
0

Check your printer settings through CUPS: http://localhost:631/printers/Xerox_Phaser_7400DN.

If you print all of your data on A4, you can change the paper size at Set Default Options.

If you only print some of your documents on A4, and some on 8.5x11, you will be better off creating a 2nd printer (with the same destination). Also, since one can specify the name the printer goes by, use a more mnemonic name.

On MY system (YMMV) I have 3 "printers" defined: deskjet with 8.5x11 paper, envelope with #10 envelopes, and Labels8163 with type 8163 labels. All three point to the same physical printer. In normal operation, deskjet is active and the other two are paused. I use cuspdisable and cupsenable to switch among them.

  • Yes, my solution was creating two printers one called XeroxPhaser7400DN_A4 and the other XeroxPhaser7400DN_A3, and setting the default options to A4 and A3. But it would be nice to be able to automatically print in A4 or A3 based on the size of the job to print, just as the Windows or MAC driver does. – leonardorame Aug 6 '18 at 22:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.