1

I'm trying to install Firefox Quantum by following what suggested by the user @cas in this question.

Everything goes right till I try to install Firefox by running in the terminal:

$ apt install -t sid firefox

Here I get the following error message:

The following packages have unmet dependencies: firefox :

Depends: libc6 (>= 2.27) but 2.24-11+deb9u3 is to be installed

Depends: zlib1g (>= 1:1.2.11.dfsg) but 1:1.2.8.dfsg-5 is to be installed

E: Unable to correct problems, you have held broken packages.

I tried to solve such issue by browsing on the internet, but nothing done! I thought to remove the package and install those ones again by it seems something unsafe because I got:

...

0 upgraded, 0 newly installed, 1802 to remove and 0 not upgraded.

After this operation, 4,562 MB disk space will be freed. You are about to do something potentially harmful. To continue type in the phrase 'Yes, do as I say!' ?]

What should I do?

2

It would seem the dependencies on Quantum has changed since the answer you link to was written - and that there's no good way of achieving your goal.

The error message you're getting mean that the currently available version of firefox in unstable depends on libc6 and zlib1g in newer versions than what are in stable, so now you can't only install quantum from unstable and have the rest of your system on stable.

As libc6 is quite fundamental (that's also why you get that strong warning when trying to remove it) I would be very hesitant to upgrade that to the version of sid if you don't know exactly what you're doing and are prepared to fix the issues that will occur. It's also likely that trying to install libc6 from unstable will require that you upgrade a lot of other packages to the versions in unstable.

  • Ok @Henrik and thanks for the answer! I would use Firefox for webscraping purposes.. in alternative I will try to use other driver as chromedriver or opera.. – Quantopik Aug 5 '18 at 22:11
  • You could also try the version of firefox that is in Debian stable. It's not the latest (it's 52.9), but it works fine (I use it daily). It's in the package called firefox-esr. – Henrik Aug 6 '18 at 5:40
  • Already tried.. unfortunately that firefox version (52.xx) does not work fine for geckodriver that needs for a version greater than 55.xx – Quantopik Aug 6 '18 at 6:05
  • Do you know any way to get some Firefox version greater than 55 in Linux Debian? – Quantopik Aug 6 '18 at 8:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.