I am planing to move form OVM to hyper-v, in-order to do the migration, I shutdown OVM (VM is using Oracle Linux 7.2) normally, then exported the appliance from OVM Console, move it to Windows machine then convert it to vhdx file using StarWind V2V Image Converter. When I start the converted VM and try to use (Oracle Linux Server (3.10.0-327.el7.x86_64 with linux) 7.2 everything is working fine without any issue, how ever if I use (Oracle Linux Server (3.8.13-98.7.1.el7uek.x86_64 with unbreakable Enterprise Linux) I got Dracut rescue mode with the following error message (shown in the attached image) enter image description here

I searched from some solution regarding this issue like executing dracut -f, edit /etc/fstab manually (note the file appears fstab.empty creating a file manually did not help at all), check if I can edit /etc/default/grub but the file dose not exist either, removing the corrupted kernel using rpm -e I got the following error "kernel dose not exit" but if I try to install it using yum or rpm it failed since the kernel exist, I have tried to fix the LVM using the solution on Redhat portal, but I got the following error message "/run/lvm/lvmetad.socket: connect failed: no such file or directory" (attaching a screen shot) enter image description here For further troubleshooting I opened "/run/initramfs/rdsosreport.txt " file and found it contains errors as shown in the screen show below enter image description here I tried to execute the commands bellow but it filed /bin/sh no such file or directory

mount --bind /proc /mnt/sysimage/proc
mount --bind /dev /mnt/sysimage/dev
mount --bind /sys /mnt/sysimage/sys
chroot /mnt/sysimage
dracut -f 
cd /
telinit 6
  • 1
    It looks like the 3.8.13 UEK initial ramdisk doesn't have the drivers for the (virtualized) disk drivers, so can't see any storage. If booting 3.10.0 does work, force reinstalling 3.8.13 UEK when booted. That should rebuild the initial ramdisk image with the correct drivers. – wurtel Aug 6 '18 at 7:07
  • Thanks @wurtel, I managed to fix the issue based on your hint, I did use a middle layer in order to do the changes at first I migrated from OVM to virtualbox, then did mac changes and fix any issue I noticed with both kernels (for 3.8.13 UEK I had to fix by reinstalling the missing parts I guess its done vie migration tool), then I migrated from Virtualbox to Hyper-v without any issue. – Ahmad Abuhasna Aug 7 '18 at 5:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.