0

I need to change the language of my PC, which is running Debian 9 Stretch with xcef4 DE.

Browsing on the official Debian website, I tried to follow what the website suggested, by running from the terminal:

  1. env | grep LANG

    and getting the following information about the language and the reference country set by default on the PC LANG=it_IT.utf8

  2. export LANG=en_IT.UTF-8

    in order to set the English language and mantain the country settings like keyboard and all the other stuff.

Anyway, no results got, because the language did not change!

Can you help me to set the English language as the default language without change the keyboard settings.

2

Just use:

dpkg-reconfigure locales

And select the default language (from the list of locales generated on the first screen (you could select several)) in the second screen.

  • hI @Isaac and thanks for the answer! Could you explain how to select the options offered by telling me which keys combo I have to use to select the option? I cannot select anything!! – Quantopik Aug 4 '18 at 11:58
  • Use the space key to place an asterisk on each language desired (to select). Use arrow keys to move up or down. Press tab to move to cancel/ok. Press arrow keys to select ok. Press enter to accept ok. Anything missing? – Isaac Aug 4 '18 at 15:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.