I am pretty much completely new to Linux, and want to tinker with it. I'm trying to set up a multiboot on a laptop, but that's irrelevant to the problem I'm having. I have partitioned my drive to have a boot (bios_grub), swap, and several ext4 partitions for my multiboot. As of now, I have only installed Mint on the third partition (following the boot and swap partitions).

When looking at the boot menu in BIOS I see nothing, unless I have my YUMI thumbdrive plugged in, in which case I can see and use only it. When booting through YUMI and selecting to boot through First HD, it puts me in the GRUB menu and I can select my Mint installation and all is well. The BIOS is definitely not UEFI, though if I recall correctly I can do some sort of override that didn't work without the thumbdrive plugged in.

Also, when I look inside the SATA Configuration menu under the Advanced tab, I can see both the HDD and SSD.

My current suspicion is that it has something to do with the secondary SSD that, if memory serves, used to boot windows 8, because from everything else I've seen it was a pretty simple fix involving resetting BIOS settings to default, disabling Secure Boot, and enabling CSM, all of which I've done. The only thing I haven't tried so far is physically resetting the CMOS settings, which I might just do after posting this because I am really at my wit's end with this, not that there was much wit to begin with. I might also try to unplug the SSD and see if that does anything while I'm inside anyway.

The computer in question (I'm fairly certain) is the ASUS TP3000LA, I believe the motherboard has the same name.

Thank you for your time.

If I understand the scenario correctly your BIOS doesn't find a valid boot device/partition when switching on the computer without your YUMI thumbdrive. It kind-off sounds like there is no valid boot record set on your partition table, which since you mentioned UEFI I presume is GPT.

Since you can boot from the thumbdrive, from a terminal you should be able to check/reinstall your bootloader (set the bootflag) on your boot partition. To check for a boot flag you can hit your drive letter with the following command:

file -Ls /dev/xvdX

You can use the same command for any partition as well, and you should see GRUB for your boot partition for example.

Then reinstall GRUB with the following commands:

grub-install /dev/xvdX
update-grub

The commands mentioned above will require to be executed with root privileges.

I hope it helps.

  • My partition table is in fact GPT, but the BIOS is most certainly not UEFI. I have 7 partitions (hopefully in the near future boot, swap, Mint, Kali, Sparky, a partition left there in case I want to install an additional OS, and the rest is a shared storage partition for moving things between OS should I need or want to.) I'm not sure which other kind of partition table will let me have this many so I went with GPT. I tried the commands you gave me and the file command said /dev/sda1 was data, I tried to fix with fdisk and gparted to no avail. – Prompted Hawk Aug 4 at 13:29
  • The output data suggest an unformatted partition, basically raw empty disk. Are you sure /dev/sda1 was infact prepared as a /boot partition? Once you boot from the thumbdrive you can check what partition /boot is mounted to by executing df /boot. – Pieter de Bruin Aug 5 at 12:04

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.