0

Friends I have downloaded tor bundle which is a standalone package. I'd like to create a custom command "torbrowser". I followed these steps,

--> I copied entire tor bundle to my /usr/local directory

--> I created a symlink of that start-tor-browser.desktop in /usr/bin which is in $PATH with the name torbrowser

when I tried to run torbrowser, it is throwing command not found. And when I try to run /usr/bin/torbrowser it is throwing permission denied. And when I tried using sudo /usr/bin/torbrowser, it says command not found. And alias works but with sudo. Tor doesn't work with sudo.

1
  • 2
    Can you post the output of ls -la /usr/bin/torbrowser ? Commented Aug 3, 2018 at 9:32

1 Answer 1

1

I think you've just forget to make torbrowser executable.

sudo chmod a+x /usr/bin/torbrowser

1
  • thank you, after seeing your answer i tried to do in CentOS. It is throwing an error chmod: cannot access ‘/sbin/start-tor-browser.desktop’: Too many levels of symbolic links . I also tried the above path with same error cannot access ‘/usr/bin/start-tor-browser.desktop’: Too many levels of symbolic links . Please let me know for any more solutions.
    – shiva
    Commented Aug 6, 2018 at 2:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .