2

I'm trying to track idle time using arbtt on a VM running Ubuntu 18.04 (using i3 on X11). arbtt uses the XScreenSaver protocol extension to get the time since the last input event, which seems to get reset about every 40 seconds. Running xprintidle in a loop shows the same result, even when I'm away from the system. There is no cursor movement (the cursor stays hidden if it was hidden before), and of course no keypresses either.

How do I find out what's causing the idle time to be reset? I've tried monitoring input events with xinput test-xi2 --root (which shows no event when the idle time gets reset) and xev -root (which doesn't seem to work at all).

The Linux system is running in VMware Workstation 12 on Windows 10, open-vm-tools are installed and the various integration features are working. It doesn't make a difference if the VM is focused, full-screen or even minimized.

  • Quick note, it appears having mpv playing a video will do this — at least with --stop-screensaver on. I think (after staring at the source & xtrace output) it's from calling XResetScreenSaver. No idea (other than xtracing everything) how to find what else calls that. The two tests you thought of, though, I can confirm do not work. – derobert Aug 2 '18 at 21:38
  • Thanks for pointing me in the right direction! In my case, it was the Microsoft Teams web client in an electron-based app I had open. Teams seems to trigger a Chromium bug which causes suspend (and screensavers) not to work - verified with chromium-browser as well. This bug just happens to have been fixed a few weeks ago (what a coincidence!), and a recent Chromium trunk build indeed doesn't have this problem. Now I just need to wait until electron picks up this fix - or, more likely, find another way of using Teams. – leromarinvit Aug 2 '18 at 23:51
  • I have the same issue in Linux when I run HipChat web in Chromium. The timer is reset every now and again and like you say nothing is in xinput. – Alex Sep 5 '18 at 10:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.