0

Running here the latest version of antiX 17.

After doing a round of upgrades, and after installing 32-bits packages for a proprietary VPN client, I am getting dependencies errors when doing a routine apt upgrade.

The error is:

The following packages have been kept back:
  xserver-xorg-core

Trying to do an apt-get install xserver-xorg-core gets back the following message:

# apt-get install xserver-xorg-core
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xserver-xorg-core : Depends: libeudev1 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Using aptitude install xserver-xorg-core to further debug the problem, I arrive to these more meaningful messages:

....
Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

      Remove the following packages:                                                        
1)      libudev-dev [220:3.2-4.0nosystemd1 (now)]                                           
2)      libudev1 [220:3.2-4.0nosystemd1 (now)]                                              
3)      udev [220:3.2-4.0nosystemd1 (now)]                                                  

      Install the following packages:                                                       
4)      eudev:i386 [232:3.2.5.3 (stretch)]                                                  
5)      libblkid1:i386 [2.29.2-1+deb9u1 (stable)]                                           
6)      libeudev1 [232:3.2.5.3 (stretch)]                                                   
7)      libeudev1:i386 [232:3.2.5.3 (stretch)]                                              
8)      libkmod2:i386 [23-2 (stable)]                                                       
9)      libpcre3:i386 [2:8.39-3 (stable)]                                                   
10)     libselinux1:i386 [2.6-3+b3 (stable)]                                                

      Keep the following packages at their current version:                                 
11)     libxfont2 [1:2.0.1-3+deb9u1 (now, stable)]                                          

      Upgrade the following packages:                                                       
12)     xserver-xorg-core [2:1.19.2-1.0nosystemd1 (now) -> 2:1.19.2-1.0nosystemd2 (stretch)]

      Downgrade the following packages:                                                     
13)     libblkid1 [2.29.2-1.0nosystemd1 (now, stretch) -> 2.29.2-1+deb9u1 (stable)]       

What to do?

0

Upon the diagnostics, I started investigating, and it seems in the latest antiX versions the default is eudev and not udev.

So I aparently replaced it as a dependency of something else I installed without noticing.

After doing then an apt-get install eudev, I was then able to do an apt-get upgrade without holding back xserver-org-core:

$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  xserver-xorg-core
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 3,373 kB of archives.
After this operation, 4,096 B of additional disk space will be used.
Do you want to continue? [Y/n] 
Get:1 http://repo.antixlinux.com/stretch stretch/nosystemd amd64 xserver-xorg-core amd64 2:1.19.2-1.0nosystemd2 [3,373 kB]
Fetched 3,373 kB in 14s (228 kB/s)                                                                                
(Reading database ... 141831 files and directories currently installed.)
Preparing to unpack .../xserver-xorg-core_2%3a1.19.2-1.0nosystemd2_amd64.deb ...
Unpacking xserver-xorg-core (2:1.19.2-1.0nosystemd2) over (2:1.19.2-1.0nosystemd1) ...
Setting up xserver-xorg-core (2:1.19.2-1.0nosystemd2) ...
Processing triggers for man-db (2.7.6.1-2) ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.