-1

I am trying to do a complete reinstall of Devuan (Debian derivative) from a USB stick on a Dell Precision 7720, but I have some issues. These are the steps:

  • From the ISO, created an USB stick with the installer with Rufus (4.5GB).
  • Boot, pressing F12 to boot from the USB stick.
  • I get to the "installer main menu"; this seems to be incomplete, with these steps only:

    • Choose language
    • Access software for blind person...
    • Configure the speech synthesizer voice
    • Configure keyboard
    • Detect and mount CD-ROM
    • Load installer components from CD
    • Change debconf priority
    • Check the CD-ROM(s) integrity
    • Save debug logs
    • Execute a shell
    • Abort the installation
  • Issues:

    • It does not ask whether I want to update or reinstall.
    • It does not ask how to partition the hard disk.
    • It asks for a CD-ROM, and does not accept the USB stick (even if the installer booted from a USB stick).

Trying to update my current Devuan, without an internet connection, I copied the installation USB key locally on the hard disk. Can I do anything with that?


These are the latest logs written by the installer:

check-missing-firmware: no missing firmware in loaded kernel modules
cdrom-detect: Searching for Debian installation media...
cdrom-detect: Devices: ''
cdrom-detect: Devices: ''
cdrom-detect: Devices: ''
cdrom-detect: Devices: ''
...
cdrom-detect: CD-ROM mount failed: device=/dev/sda1 fstype=iso9660
cdrom-detect: CD-ROM mount failed: device=/dev/sda1 fstype=vfat
cdrom-detect: CDROM-detect failed: unmounting CD just to be sure
main-menu[424]: (process:2599): mount: mounting /dev/sda1 on /cdrom failed: Invalid argument
main-menu[424]: (process:2599): mount: mounting /dev/sda1 on /cdrom failed: Invalid argument
main-menu[424]: WARNING **: Configuring 'cdrom-detect' failed with error code 1


Reference (link): tried it, with no success.

  • 1
    It’s worth noting that some installation menu entries appear after the “Load installer components from CD” step has completed. I think this includes the partitioning step. Look at the console (Alt+F4) to see details of what the installer is doing when it looks for the ISO image. – Stephen Kitt Jul 31 '18 at 15:54
  • The problem is that I have neither a CD nor a CD drive, so I cannot go beyond that step. I am copying some logs in the original question... – Pietro Jul 31 '18 at 16:07
  • 1
    “from CD” really means “from ISO image”, wherever that is — on a physical CD or on a USB key as is your case. If you look at the contents of the installation USB key, you should see an ISO image somewhere; that’s what the installer is looking for. The logs should tell you where it’s looking. – Stephen Kitt Jul 31 '18 at 16:14
  • On the USB key there are no ISO files (I have an isolinux directory). I created the contents from the devuan_ascii_2.0.0_amd64_dvd-1.iso file. I think at this point the ISO file should not be needed any more... – Pietro Jul 31 '18 at 16:26
  • Sorry, you’re right, the ISO image isn’t necessary. – Stephen Kitt Jul 31 '18 at 16:31
0

I solved my problem writing a DD image on the USB stick, instead of an ISO image.

Doing so, I can get the complete set of installation steps.

Using the Rufus tool, there is no such option on the main dialog, but after you click to confirm the formatting, another dialog allows to select whether to generate an ISO (default) or DD image.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.