3

I'm using screen terminal multiplexer.

For some reason a dashed line appears on the 10th row.

...
[ec2-user@ip-172-31-1-24 var]$ ls
account  db     games     lib    lock  mail  opt       run    tmp  yp
cache    empty  kerberos  local  log   nis   preserve  spool  www
[ec2-user@ip-172-31-1-24 var]$
----------------------------------------------------------------------------




...

My available work area was limited to a few lines.

What does this means, and how can I recover the entire workspace?

4

I'd like to present another answer that might help other users who come across this:

On GNU Screen by default, the dashed line means something else than what @slm said. His answer was covering tmux. For screen splitting (CTRL + A + S) in screen, the line is made out of solid full block characters. ()

The dashed line on screen is being used to show the window borders of the display/terminal which first attached the screen session. I'll give an example:

You have a 1280x1024px monitor on which you start a screen session on a fullscreen terminal. Now on another machine, with a 1920x1200px monitor and a fullscreen terminal, you execute screen -x <session>, entering multi-display mode. On that terminal you will now see dashed-lines the size of your first terminal, and you won't be able to use more space until you detach (-d) the screen from the other terminal. This is to ensure that every attached terminal always sees all the contents.

  • Good call, I missed that the OP was using screen I thought they were using tmux. – slm Jul 31 '18 at 20:33
  • The "made out of solid full block characters" wasn't a typo though. I'm talking about the "Full block" unicode character (U+2588 ()). – confetti Jul 31 '18 at 20:45
  • I looked in the edit history, I didn't see that until your latest edits, did you add it previously or thought you had but maybe forgot? – slm Jul 31 '18 at 22:19
  • 1
    I didn't have it at first, just added it with the last edit to be more clear. – confetti Aug 1 '18 at 0:31
2

TLDR;

I originally took the question to be about tmux but it was apparently about screen. Edits to the question showed this to be the situation later on. I'm leaving this here in case someone else has this same question/issue with tmux.


Based on what you're showing it sounds like your split pane borders are being shown as dashes. You likely did this with a Ctrl+b+".

ss1

If you use Ctrl+b+n you can switch to the next pane and attempt to close it by typing exit or Ctrl+d.

What about the dashes

The dashes appear to be due to this option in your terminal. In iterm2 on OSX, for example, you can go into this menu and disable this rendering: Preferences → Profiles → Text and change the setting of "Treat ambiguous-width characters as double-width."

ss2

Once you've got the settings in place, the dashes should look like a solid line:

enter image description here

If you find the above is not your issue, it may in fact be due to the font you're using. Your font just may not have an appropriate glyph, and so the dashes are what get used.

If you feel this is your issue, take a look at this SO Q&A titled: Tmux borders are drawn with dashed lines; how can I change them to continuous lines?.

References

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.