1

I'm currently trying to run a guest virtual machine on my current system (Ubuntu 18.04 with the 4.15.0-29-generic kernel).

Every time I've tried running a virtual machine (I've tried virtualbox aswell as kvm) my host system completely freezes and I have to reboot in order for the system to be responsive again.

The freeze seems to occur when the guest is processing some task (for example downloading a large package using apt).

I'm very new to Linux and so I'm essentially looking for a good way to troubleshoot this issue. I'm not too familiar with how I would go about this.

I've tried a couple of fresh installs but the issue still occurs.

I've checked the syslog and this is what is logged right before the crash happens:

kernel: [  863.019124] vboxdrv: 0000000000000000 VMMR0.r0
kernel: [  863.142264] vboxdrv: 0000000000000000 VBoxDDR0.r0

After that there's a bunch of "^@^@^@^" until the next message in the log which is the system restarting.

In "journalctl" I can see a number of errors happening at the time of the freeze, for example, a lot of them are variations of this with different numbers displaying:

kernel: swap_info_get: Bad swap file entry 2200000000000000
kernel: BUG: Bad page map in process EMT-1  pte:00002200 pmd:32fb78067
kernel: addr:00000000fc73a6db vm_flags:1c0400fb anon_vma:          (null) mapping:000000009d3746ac index:c3
kernel: file:dev/zero fault:shmem_fault mmap:shmem_mmap readpage:          (null)

Here's another:

BUG: Bad page map in process EMT-1  pte:0000a100 pmd:32fb78067
page:ffffdceb80000280 count:1 mapcount:-1 mapping:0000000000000000 index:0x0
flags: 0x7ffffc0000800(reserved)
raw: 0007ffffc0000800 0000000000000000 0000000000000000 00000001fffffffe
raw: ffffdceb800002a0 ffffdceb800002a0 0000000000000000 0000000000000000
page dumped because: bad pte
addr:00000000f6ef20c2 vm_flags:1c0400fb anon_vma:          (null) mapping:000000009d3746ac index:c4
file:dev/zero fault:shmem_fault mmap:shmem_mmap readpage:          (null)

I realise this may not be enough information to go on, but with my limited knowledge I'm unsure as to what information I should provide. Please let me know if there's something else I should include and I'll enter it.

Could anyone point me in the right direction as to how to diagnose the issue and fix it?

closed as off-topic by Jeff Schaller, schily, Rui F Ribeiro, slm Aug 12 '18 at 14:17

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, schily, Rui F Ribeiro, slm
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Most likely bad RAM. Run memtest on it. – Rui F Ribeiro Jul 30 '18 at 13:50
  • Spot on! I reseated the RAM and that was enough to stop the issue! I now feel stupid for having wrestled with this for the last two weeks! Thank you. – James H. Jul 30 '18 at 15:50