0

Running yum install openssl-devel leads to dependency checking errors and do not install it. I guess there is a problem in my repositories however I don't know what is wrong with my installed version of CentOS (Linux release 7.5.1804) but I usually need to run yum with --skip-broken parmeter. I guess I should set priority for my repositories.

Here is the contents of CentOS-Base.repo

[root@server1 ~]# cat /etc/yum.repos.d/CentOS-Base.repo
# CentOS-Base.repo
#
# The mirror system uses the connecting IP address of the client and the
# update status of each mirror to pick mirrors that are updated to and
# geographically close to the client.  You should use this for CentOS updates
# unless you are manually picking other mirrors.
#
# If the mirrorlist= does not work for you, as a fall back you can try the
# remarked out baseurl= line instead.
#
#

[base]
name=CentOS-$releasever - Base
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os&infra=$infra
#baseurl=http://mirror.centos.org/centos/$releasever/os/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-7

#released updates
[updates]
name=CentOS-$releasever - Updates
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=updates&infra=$infra
#baseurl=http://mirror.centos.org/centos/$releasever/updates/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-7

#additional packages that may be useful
[extras]
name=CentOS-$releasever - Extras
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=extras&infra=$infra
#baseurl=http://mirror.centos.org/centos/$releasever/extras/$basearch/
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-7

#additional packages that extend functionality of existing packages
[centosplus]
name=CentOS-$releasever - Plus
mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=centosplus&infra=$infra
#baseurl=http://mirror.centos.org/centos/$releasever/centosplus/$basearch/
gpgcheck=1
enabled=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-7

Here is the erros in output of yum install openssl-devel which prompted during dependency checking:

Error: Package: dracut-network-033-240.el7.x86_64 (@anaconda)
           Requires: dracut = 033-240.el7
           Removing: dracut-033-240.el7.x86_64 (@anaconda)
               dracut = 033-240.el7
           Updated By: dracut-033-535.el7.x86_64 (base)
               dracut = 033-535.el7
           Removing: dracut-033-502.el7.x86_64 (installed)
               dracut = 033-502.el7
           Updated By: dracut-033-535.el7.x86_64 (base)
               dracut = 033-535.el7
Error: Package: libss-1.42.9-7.el7.x86_64 (@anaconda)
           Requires: libcom_err(x86-64) = 1.42.9-7.el7
           Removing: libcom_err-1.42.9-7.el7.x86_64 (@anaconda)
               libcom_err(x86-64) = 1.42.9-7.el7
           Updated By: libcom_err-1.42.9-12.el7_5.x86_64 (updates)
               libcom_err(x86-64) = 1.42.9-12.el7_5
           Removing: libcom_err-1.42.9-10.el7.x86_64 (installed)
               libcom_err(x86-64) = 1.42.9-10.el7
           Updated By: libcom_err-1.42.9-12.el7_5.x86_64 (updates)
               libcom_err(x86-64) = 1.42.9-12.el7_5
           Available: libcom_err-1.42.9-11.el7.x86_64 (base)
               libcom_err(x86-64) = 1.42.9-11.el7
Error: Package: systemd-sysv-208-20.el7.x86_64 (@anaconda)
           Requires: systemd = 208-20.el7
           Removing: systemd-208-20.el7.x86_64 (@anaconda)
               systemd = 208-20.el7
           Updated By: systemd-219-57.el7.x86_64 (base)
               systemd = 219-57.el7
           Removing: systemd-219-42.el7_4.4.x86_64 (installed)
               systemd = 219-42.el7_4.4
           Updated By: systemd-219-57.el7.x86_64 (base)
               systemd = 219-57.el7
Error: Package: systemd-python-208-20.el7.x86_64 (@anaconda)
           Requires: systemd = 208-20.el7
           Removing: systemd-208-20.el7.x86_64 (@anaconda)
               systemd = 208-20.el7
           Updated By: systemd-219-57.el7.x86_64 (base)
               systemd = 219-57.el7
           Removing: systemd-219-42.el7_4.4.x86_64 (installed)
               systemd = 219-42.el7_4.4
           Updated By: systemd-219-57.el7.x86_64 (base)
               systemd = 219-57.el7
Error: Package: e2fsprogs-libs-1.42.9-7.el7.x86_64 (@anaconda)
           Requires: libcom_err(x86-64) = 1.42.9-7.el7
           Removing: libcom_err-1.42.9-7.el7.x86_64 (@anaconda)
               libcom_err(x86-64) = 1.42.9-7.el7
           Updated By: libcom_err-1.42.9-12.el7_5.x86_64 (updates)
               libcom_err(x86-64) = 1.42.9-12.el7_5
           Removing: libcom_err-1.42.9-10.el7.x86_64 (installed)
               libcom_err(x86-64) = 1.42.9-10.el7
           Updated By: libcom_err-1.42.9-12.el7_5.x86_64 (updates)
               libcom_err(x86-64) = 1.42.9-12.el7_5
           Available: libcom_err-1.42.9-11.el7.x86_64 (base)
               libcom_err(x86-64) = 1.42.9-11.el7
Error: Package: libselinux-python-2.2.2-6.el7.x86_64 (@anaconda)
           Requires: libselinux = 2.2.2-6.el7
           Removing: libselinux-2.2.2-6.el7.x86_64 (@anaconda)
               libselinux = 2.2.2-6.el7
           Updated By: libselinux-2.5-12.el7.x86_64 (base)
               libselinux = 2.5-12.el7
           Removing: libselinux-2.5-11.el7.i686 (installed)
               libselinux = 2.5-11.el7
           Updated By: libselinux-2.5-12.el7.i686 (base)
               libselinux = 2.5-12.el7
Error: Package: e2fsprogs-1.42.9-7.el7.x86_64 (@anaconda)
           Requires: libcom_err(x86-64) = 1.42.9-7.el7
           Removing: libcom_err-1.42.9-7.el7.x86_64 (@anaconda)
               libcom_err(x86-64) = 1.42.9-7.el7
           Updated By: libcom_err-1.42.9-12.el7_5.x86_64 (updates)
               libcom_err(x86-64) = 1.42.9-12.el7_5
           Removing: libcom_err-1.42.9-10.el7.x86_64 (installed)
               libcom_err(x86-64) = 1.42.9-10.el7
           Updated By: libcom_err-1.42.9-12.el7_5.x86_64 (updates)
               libcom_err(x86-64) = 1.42.9-12.el7_5
           Available: libcom_err-1.42.9-11.el7.x86_64 (base)
               libcom_err(x86-64) = 1.42.9-11.el7
Error: Package: dracut-config-rescue-033-240.el7.x86_64 (@anaconda)
           Requires: dracut = 033-240.el7
           Removing: dracut-033-240.el7.x86_64 (@anaconda)
               dracut = 033-240.el7
           Updated By: dracut-033-535.el7.x86_64 (base)
               dracut = 033-535.el7
           Removing: dracut-033-502.el7.x86_64 (installed)
               dracut = 033-502.el7
           Updated By: dracut-033-535.el7.x86_64 (base)
               dracut = 033-535.el7
Error: Package: libselinux-utils-2.2.2-6.el7.x86_64 (@anaconda)
           Requires: libselinux = 2.2.2-6.el7
           Removing: libselinux-2.2.2-6.el7.x86_64 (@anaconda)
               libselinux = 2.2.2-6.el7
           Updated By: libselinux-2.5-12.el7.x86_64 (base)
               libselinux = 2.5-12.el7
           Removing: libselinux-2.5-11.el7.i686 (installed)
               libselinux = 2.5-11.el7
           Updated By: libselinux-2.5-12.el7.i686 (base)
               libselinux = 2.5-12.el7
Error: Package: libgudev1-208-20.el7.x86_64 (@anaconda)
           Requires: systemd = 208-20.el7
           Removing: systemd-208-20.el7.x86_64 (@anaconda)
               systemd = 208-20.el7
           Updated By: systemd-219-57.el7.x86_64 (base)
               systemd = 219-57.el7
           Removing: systemd-219-42.el7_4.4.x86_64 (installed)
               systemd = 219-42.el7_4.4
           Updated By: systemd-219-57.el7.x86_64 (base)
               systemd = 219-57.el7
Error: Package: krb5-workstation-1.12.2-14.el7.x86_64 (@anaconda)
           Requires: krb5-libs(x86-64) = 1.12.2-14.el7
           Removing: krb5-libs-1.12.2-14.el7.x86_64 (@anaconda)
               krb5-libs(x86-64) = 1.12.2-14.el7
           Updated By: krb5-libs-1.15.1-19.el7.x86_64 (updates)
               krb5-libs(x86-64) = 1.15.1-19.el7
           Removing: krb5-libs-1.15.1-8.el7.x86_64 (installed)
               krb5-libs(x86-64) = 1.15.1-8.el7
           Updated By: krb5-libs-1.15.1-19.el7.x86_64 (updates)
               krb5-libs(x86-64) = 1.15.1-19.el7
           Available: krb5-libs-1.15.1-18.el7.x86_64 (base)
               krb5-libs(x86-64) = 1.15.1-18.el7
 You could try using --skip-broken to work around the problem

** Found 936 pre-existing rpmdb problem(s), 'yum check' output follows:
ModemManager-1.6.0-2.el7.x86_64 is a duplicate with ModemManager-1.1.0-6.git20130913.el7.x86_64
ModemManager-glib-1.6.0-2.el7.x86_64 is a duplicate with ModemManager-glib-1.1.0-6.git20130913.el7.x86_64
1:NetworkManager-1.8.0-11.el7_4.x86_64 is a duplicate with 1:NetworkManager-1.0.0-14.git20150121.b4ea599c.el7.x86_64
2

It seems as if either your RPM DB or YUM are out of sync and/or date with each other or their upstreams.

I'd do the following:

$ sudo yum clean all
$ sudo yum update -y

If things still seem hung up check to make sure you don't have RPMs installed that are from a YUM repo that was out of sync. You'll typically see packages installed multiple times:

$ sudo rpm -qa | grep -i 'dracut'

You'll see 2 items with the same name if this is the case. To resolve it you typically remove it, but this might choose challenging. You could try doing this:

$ sudo yum reinstall <pkg>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.