5

I try to decrypt my harddrive using the password that I 100% know. The password knowledge is not the problem.

Last thing I remember doing is: installing texlive. Not having enough disk space. Removing texlive again. followed by

apt update 
apt upgrade
apt dist-upgrade

I remember the update had an error due to missing internet connection (wifi switch was off) After I switched on wifi, update, upgrade and dist-upgrade went (I don't remember otherwise) smoothly.

Starting my machine this morning brings me to the current state of affairs:

No key available with this passphrase
cryptsetup failed. bad password or option?

The password contains special characters - can I somehow test which symbols are created by a keypress? Maybe the keyboard layout switched or somithing similar.

This problem is on Debian Jessie. Except for header backups, what else can help me investigate?

  • 1
    Did your keyboard layout change for whatever reason, causing you to mistype the passphrase? – Kusalananda Jul 29 '18 at 10:13
  • First thing I'd have tried from the GRUB menu would be to if using an older kernel changed anything. I also would have avoided special characters in the password, but that's of course not a lot of help after the fact. – kasperd Jul 29 '18 at 16:57
11

In GRUB (or whatever you're using as your bootloader), add this boot option to your kernel command line: break=premount. It should give you a shell prompt while the system is still running on initramfs and the system has not yet made any attempts to mount the real root filesystem.

You can use this shell prompt to check your keyboard layout.

|improve this answer|||||
  • 2
    It was the special Characters. Keybiardlayout changed. Thank you! – Ok Letsdothis Jul 29 '18 at 11:20
  • By the way: actually just pressing 'c' brought me to a commandline from Grub2 – Ok Letsdothis Jul 29 '18 at 11:22
  • 2
    Pressing 'c' brings you to the GRUB command prompt, which typically always uses the US English keyboard layout unless you customize your GRUB configuration specifically for that. This may or may not be the same keyboard layout the cryptsetup password prompt uses. (However, if a keyboard layout gets changed on update, the most likely change is a fallback to factory default US English.) – telcoM Jul 29 '18 at 11:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.