0

I have installed Linux deepin os on my laptop which I have been using for the past 6 months now, the past two weeks,the computer slows down and when I save a file, I get and error Read-only file system. I have two ext4 partitions /dev/sda1(is bootable and has home partition) and /dev/sda3. It's affecting the two partitions.

I have been fixing this using this command as explained in this question.

$ sudo fsck.ext4 /dev/sda1

Here is a screenshot of the output when I run the above command.

enter image description here

This fixes the problem but it happens at least twice a day, affecting my work significantly. I need to fix this issue permanently.

  • 1
    I'm assuming your ran this on unmounted partitions? How old is the disk? – Kusalananda Jul 28 '18 at 7:06
  • Could also be dodgy RAM, with the in-memory filesystem structures getting failures. Running memtest just in case might be a good idea. (It's a startup option on most Linux install media I've seen.) – Ulrich Schwarz Jul 28 '18 at 7:21
  • @Kusalananda, yes am running the command when unmounted. Am not sure how old the laptop is but can't be older than 4 years. – Joe Nyugoh Jul 29 '18 at 18:45
3

The filesystem going readonly by itself is very likely the result of the filesystem driver encountering errors. You might see the errors=remount-ro option in the output of mount. It does that to protect the filesystem from further issues. (The alternatives are to continue and ignore the error, or to panic the system, see ext4(5)). You should probably see something about the error in dmesg.

If it happens repeatedly, it's an indication of the hardware going bad. Check at least the disk and memory, and make backups while you can.

  • How do I get more information about the filesystem driver errors? Below is the output of dmesg – Joe Nyugoh Jul 29 '18 at 19:30
  • joe@jarvis  ~  dmesg | grep mount [ 5.306033] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null) [ 8.798523] EXT4-fs (sda1): re-mounted. Opts: data=ordered [ 45.261146] EXT4-fs (sda3): mounted filesystem with ordered data mode. Opts: (null) [ 45.261199] partition /media/joe/Jarvis [8, 3] added, comm[1701]: mount – Joe Nyugoh Jul 29 '18 at 19:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.