3

curl started acting strange for me in last few days, its double underscoring when reading headers:

enter image description here

With -i it just double-underscores everything after header as well:

enter image description here

When just reading body it outputs as expected:

enter image description here

I have tried -IX GET as well just to rule off HEAD request, it was same. Worth noting also, I use guake, tho I have tried default terminal and it acts same.

Further troubleshooting

  • Created new user, tested with it to avoid profile changes Ive made, still an issue.

  • Tried from TTY, does not underline but prints out light blue letters where there would be underline in terminal.

  • Curl version = curl 7.61.0

Googling is not helping much, stuck at the moment, any ideas?

  • it wont show underlines @Jesse_b – Dusan Gligoric Jul 26 '18 at 15:46
  • 1
    Seems like it may be an issue with your terminal application – Jesse_b Jul 26 '18 at 15:49
  • tried default terminal, usually using guake @Jesse_b – Dusan Gligoric Jul 26 '18 at 15:49
  • Is your PS1 supposed to be underlined? – jeremysprofile Jul 26 '18 at 16:06
  • not that I know of, this only happens so far with curl @jeremysprofile – Dusan Gligoric Jul 26 '18 at 16:11
2

The release notes for curl 7.61 note the following new feature:

curl: show headers in bold, switch off with --no-styled-output

The comments on the linked pull request suggest the double underlining you and I am seeing is the result of a bug in this feature where the "boldness" is not being turned off properly. It is possible that the changes in https://github.com/curl/curl/pull/2738 will fix this in a future curl version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.