1

How can I get Linux fully installed and operational on a 2 in 1 Trio Windows 10.1 OD Tablet?

( http://www.triotablets.us/tablets/windows-tablets/pro-book-10-1/ )

It utilizes a 32 bit U/EFI and a 64 bit Intel Atom (baytrail) processor.

I’ve tried various distros and guides, including but not limited to (with little to no success):

[ISOs]
linuxium-atom-ubuntu-16.04.4-desktop-amd64.iso
linuxium-atom-ubuntu-18.04-beta2-desktop-amd64.iso
communitheme.atom.linuxium-atom-v4.17-cosmic-desktop-amd64.iso
debian-9.5.0-amd64-DVD-1.iso
linuxmint-19-xfce-64bit-v2.iso

[Guides]
https://medium.com/@realzedgoat/a-sorta-beginners-guide-to-installing-ubuntu-linux-on-32-bit-uefi-machines-d39b1d1961ec
https://www.reddit.com/r/linuxquestions/comments/8j2zjc/running_distros_on_cheap_intel_atom_bay_trail/
https://linuxiumcomau.blogspot.com

I’ve annoyed and pissed off countless people in IRC chat channels inquiring about my problem…
Freenode  ##linux , ##linuxmint
SpontChat #linuxmint-chat , #linuxmint-help

[Progress]

The furthest I can get is the following procedure:

1.) I create a Linux Mint Installation Media with: linuxmint-19-xfce-64bit-v2.iso using UNetbootin to extract the image on a FAT32 formatted 8GB SanDisk USB thumb drive stick.

2.) I add the file: bootia32.efi (from: https://github.com/hirotakaster/baytail-bootia32.efi/blob/master/bootia32.efi ) to the /EFI/BOOT/ folder of the SanDisk USB stick to allow 32 bit EFI Booting.

3.) At GRUB I must select the first option and hit “e” to edit and add: “nomodeset” flag right before: “quiet splash” section. While editing I have to use FN + Ins/NumLk, to disable numlock otherwise my “o” key becomes a “6”. (Obviously NumLock is working and is On at boot.) (I must add “nomodeset” or GRUB doesn’t boot any further just to a black screen and freezes)

4.) After Pressing FN+End/F10 to save and boot I wait and see the splash logo and then eventually reach a live session.

5.) The screen is turned sideways and is unable to be corrected in display settings or using xrand :

https://imgur.com/a3uIEYk (probably due to the “nomodeset” flag and dimensions not being able to be obtained.)

6.) I connect to the Wi-Fi internet (I noticed that if I don’t do this I get multiple errors during installation about GRUB and the EFI and the partitions and accessing them or mounting them or unmounting them) I run the installation and select most all defaults including whipping the drive and letting the installer partition for me. I finish the installation with no errors.

7.) I get the notice that I can keep testing or reboot, I choose to keep testing so I can see the destination of where it put my installation and how it mapped my partitions using gparted: https://imgur.com/OEUn8RO

8.) I close out of Gparted, shut down the device.

9.) Upon reboot I can get to GRUB either from the install or from the live session, but after this no further unless I boot into the live session with the “nomodeset” option. But the “nomodeset” option doesn’t help any on the Installed session.

9.5) I try some recommendations and plea for help:http://dpaste.com/3AZR8GE 9.5.1) I try at grub> linux /casper/vmlinuz root=/dev/mmcblk1p2 No error but returned to grub prompt, boot fails at frozen black screen (no further)

Note: Sometimes GRUB loads and sometimes it doesn’t, it’s affected by BIOS auto arranging the boot order, so I have to enter BIOS and set boot order properly and even sometimes then it doesn’t boot to GRUB, but other times it will.

But I’m currently setting at a GRUB version 2.02 screen with no attached media showing the options: Linux Mint 19 Xfce *Advanced options for Linux Mint 19 Xfce System setup

Waiting for a response or a drop to a command line or an edit. Where do I go from here, how can I get Linux functional on this system/device?

[Working in Live Session]
GRUB
Keyboard
Trackpad with all features
WiFi
SD Card reader

[Not Working in Live Session]
BlueTooth
{Screen is rotated and cannot be corrected}

[Unsure if Working in Live Session]
Webcam

[Working in Installation]
GRUB (sometimes)

[Not Working in Installation]
{everything, won’t boot up into system}
  • dpaste.com/1QT12ZF – CyberManifest Jul 25 '18 at 23:29
  • @roaima I don't know how, when I copied and pasted it, StackExchange changed my formatting and I don't understand it's incoherent formatting tools. I also don't know how to make Imgur images inline as they don't have a file extension they are just a link. – CyberManifest Jul 25 '18 at 23:39
  • You have a real challenge ahead of you. Who knows what hardware is in there, and what special boot/bios protections and issues were in there. Tablets are much closer to phones than laptops/desktops and often very much custom built. You are making progress, which is impressive, but honestly you might do better to just put it's original OS back on it and run a VM of linux. – bashCypher Jul 25 '18 at 23:40
  • @bashCypher I lost my original OS when I nuked it to put linux on. No installation media came with the device and I'm not sure about reactivating licensing and/or if it was a special OEM edition. So that doesn't seem to be an option... there's like no going back now. – CyberManifest Jul 25 '18 at 23:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.