Linux Mint 19 x64 with Cinnamon

Whenever I try to install a .deb by double clicking the file and clicking "Install Package" on the Package Installer popup, I get the following error:


There seems to be a programming error in aptdaemon, the software that allows you to install/remove software and to perform other package management related tasks.

org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message but without replying.

I can run apt update and upgrade just fine. I think something went wrong with an install I did awhile back using dpkg from the command line. I cannot find any details about how to fix this. Any ideas?

EDIT: I also can't install things from the Software Manager GUI. I've tried reinstalling both mintinstall, mintupdate, and gdebi but my situation has not changed after doing so. Can't uninstall through the GUI either.

EDIT 2: I've found that I can't open synaptic from the menu. If I run synaptic-pkexec from the command line I get the following output:

Error checking for authorization com.ubuntu.pkexec.synaptic: GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying

Which leads me to think my problem might have to do with policykit but I don't know enough about policykit. policykit-desktop-privileges seems to an aid for users in the admin or sudo groups that run common tasks as sudo for them automatically. When I double click a deb file and the gdebi-gtk no problem arises until it would normally ask for my sudo password.

How do I troubleshoot potential issues with policykit?

EDIT 3: The problem seems to be rooted in Policy Kit so I've edited the question. I have a stable install of Linux Mint 19 x64 on my laptop and have been comparing my desktop's behavior to the laptop. On my laptop I run pkexec nano and the UI pops up asking for my password for sudo and running nano when I give the password. On my server, where I'm having the problem, when I run pkexec nano instead of the UI popup I expect, I get the same output I get when running synaptic-pkexec (except it says com.ubuntu.pkexec.exec instead of synaptic).

From some googling it seems that the default policy kit is supposed to be /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1. When I run the file I get:

** (polkit-gnome-authentication-agent-1:13684): WARNING **: 10:10:40.701: Unable to register authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject

I'm not sure if there's a way to find what is the current authentication agent. I do have a service called polkit that's active and doesn't seem to be throwing any errors. I've checked the log in /var/log/auth.log but it doesn't contain any errors. When I do the above pkexec nano the log prints the following:

Aug 9 10:14:44 MyComputerName polkitd(authority=local): Registered Authentication Agent for unix-session:c2 (system bus name :1.56 [/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1], object path /org/gnome/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)

This feels like polkit-gnome-authentication-agent-1 is active and running but apparently improperly.

I also find it weird that I can run sudo apt update and get prompted for my password properly (and it executes properly when given the password). I thought polkit would be in charge of that and it seems broken.

  • Did you download in Firefox and choose to open with Gdebi?
    – Jeremy31
    Commented Jul 25, 2018 at 22:27
  • I don't use Firefox. I'm double clicking the file in my Downloads folder. The package is for GitKraken, it downloaded it's own .deb update for me to install. Commented Jul 26, 2018 at 2:34
  • 1
    simply use apt install "package name". instead of downloading .deb file
    – user
    Commented Jul 26, 2018 at 4:19
  • What if my package isn't in the repo? GitKraken happens to be but there might be times I'd rather install a .deb file than add a PPA. Circumventing the problem isn't a fix. Commented Jul 26, 2018 at 15:36
  • 1
    @GAD3R I've been updating my question recently. I don't think it's specific to the package manager at all. I think I just noticed a policy kit problem while using the package manager to install deb files I've downloaded from elsewhere. Starting from Edit #2 to the details I just added, I detail how I can't use pkexec to run synaptic or any executable. Commented Aug 9, 2018 at 16:21

1 Answer 1


I'm on Debian with KDE.

I had the symptoms you had: when started from menu, synaptics would not show the usual authentication pop-up. In the terminal, sudo synaptics worked.

journalctl (polkit segmentation faults) and learning that menu entry synaptics actually runs synaptics-pkexec got me here.

On https://forums.linuxmint.com/viewtopic.php?t=302811 I read that someone managed to get rid of the issue by removing a file created while installing xRDP. Go to


and remove


It worked for me instantly even without restarting polkit (sudo systemctl restart polkit.service).

  • 1
    This solved an issue for me on Ubuntu 18.04 where policykit wasn't letting me format a USB drive. Thank you! Commented May 13, 2020 at 5:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .