1

I'm currently running RHEL7. I haven't been able to find a definitive explanation of how to disable core dump files. I can limit to number of core files that are produced, but I don't know how to disable them entirely. I limited the number of core files that get generated by adding

   kernel.core_uses_pid = 0
   kernel.core_pattern = core

to /etc/sysctl.conf

and running sudo sysctl -p

This limits core file generation to a single file that gets rewritten each time there's a core dump. But I'd like to stop this file from being generated altogether. Thanks!

EDIT: I also tried this:

Add the line Storage:none to

/etc/systemd/coredump.conf

This didn't change anything, core files still get produced.

bumped to the homepage by Community 2 days ago

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

  • 1
    This may be related - unix.stackexchange.com/questions/182820/… – thebtm Jul 25 '18 at 18:26
  • check /lib/systemd/system/kdump.service. You can use systemctl stop kdump and systemctl disable kdump.Actually you need to turning linux kernel. Maybe you ran application that needed turning kernel. – supriady Jul 26 '18 at 13:36
  • "Actually you need to turning linux kernel. Maybe you ran application that needed turning kernel. " Thank you for your help. Could you please clarify this? – GreNIX Jul 26 '18 at 13:39
0

I think core dump generation is related to ABRT. Can you check if the following services are running ?

systemctl status abrtd

systemctl status abrt-ccpp

And if they are, stop and disable them ( systemctl stop / disable )

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.