0

I have an NFS server configured and its up and running without an issue. But I need to enable the no_wdelay option on the exports. I have modified the /etc/exports file to be as following(added no_wdelay option):

/exports 10.0.3.10/8(rw,sync,no_subtree_check,all_squash,no_wdelay)

So I want to apply the above changes to the nfs server. I have tried the following commands.

  1. sudo exportfs -ra
  2. sudo systemctl try-restart nfs-config.service rpcbind.service rpc-statd.service nfs-server.service
  3. sudo systemctl restart nfs-server
  4. sudo service nfs-kernel-server restart
  5. sudo service nfs-server restart
  6. sudo /etc/init.d/nfs-kernel-server restart

But when I check the status using sudo /usr/sbin/exportfs -v or exportfs -v it gives the output which doesn't have the no_wdelay option:

/exports    10.0.3.10/8(rw,root_squash,all_squash,no_subtree_check,sec=sys,rw,root_squash,all_squash)

The content of /var/lib/nfs/etab shows that no_wdelay option is there:

/exports 10.0.3.10/8(rw,sync,no_wdelay,hide,nocrossmnt,secure,root_squash,all_squash,no_subtree_check,secure_locks,acl,anonuid=65534,anongid=65534,sec=sys,rw,root_squash,all_squash)

What am I doing wrong ? Is the option getting applied or not ? What is the correct way to check this ?

System Info:

uname -a
Linux nfs-server 4.13.0-1012-gcp #16-Ubuntu SMP Thu Mar 15 12:00:42 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
  • Have you remounted the file system on the client? – Raman Sailopal Jul 24 '18 at 11:51
  • @RamanSailopal No I havent, do I need to remount it ? I couldnt find any reference where remounting is required. – hYk Jul 24 '18 at 13:27
  • It's worth a try? Even on a test setup – Raman Sailopal Jul 24 '18 at 13:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.