On Linux Mint 18.3 (x64) MATE, I had the standard volume and networking tray icons.

After upgrading in-place to Linux Mint 19, it apparently decided XFCE is what I wanted (but I can choose between the two on the login screen.) However, no matter what I choose, there are no volume and networking icons in the tray.

As you can see, I've tried enabling everything indicator-, volume-, and network-related:

...but after a full reboot there's still nothing in the tray except the clock and the "show desktop" icon.

This is true whether I log into MATE or XFCE.

Update: In Xfce, I found this dialog in the Panel settings, and upon enabling the notification area frame, I discovered that in fact, the volume control is there, but invisible (you can see the control popup in this screenshot, just after I've clicked the blank area beside the update icon):

(And yes, now I've done every available update and rebooted again, and still have the same result.)

Update 2: I've confirmed that the invisible volume control icon is mate-volume-control-applet, the one at the bottom of the list in the first screenshot. Maybe I shouldn't have it enabled since it's MATE under Xfce, but as I said, there was no volume icon out of the box.

Meanwhile, the network icon seems to be nm-applet, which was running. I killed it and tried restarting it from the command line, and got this:

~ $ nm-applet &
[1] 3982
~ $ 
(nm-applet:3982): Gtk-WARNING **: 10:39:43.816: Can't set a parent on widget which has a parent

How can I get the network icon back, and make the volume icon visible again?

Update: On a cold boot, after removing some items from the startup list (including the volume and update services), I now see only a blank/invisible icon which turns out to be nm-applet (I can right-click the blank space and see WiFi hotspots.) Can I only have one or the other? And why are they invisible?

Increase the maximum icon size until it becomes visible.

Note: This only worked on the network icon. Some reboots later (without any configuration changes on my part) both icons are present, but the volume icon is still invisible, no matter what the maximum icon size.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.