On Gnome 9.5, if I use VScode's "Zen Mode" (ctrl-k + z) or fullscreen mode (f11), gnome-shell CPU usage (viewed through top) skyrockets from 0-10% usage to 80-100%. This happens even if I quickly enter and exit "Zen Mode," or even if I enter Zen Mode and then close VScode. With the program closed, gnome-shell usage will be stuck at 80%-100% until a full system restart.

OS Version: Debian GNU/Linux 9.5 (stretch) 64-bit
Gnome V 3.22.2
10.8GiB RAM
Intel Core i7-8650U @ 1.9GHz x 4
Graphics: Chromium 

Running in a VirtualBox Windows 10 Host.

I have tried many versions of VScode, including old versions and version on a currently working machine. I have tried completely purging VScode and reinstalling (for all version attempts). I have completely reinstalled both Gnome on this Debian installation, as well as started a from-scratch Debian installation.

This issue is not duplicated on my other machine running Debian 9.3, with the same version of Gnome (installed natively). When I have time, I will try to duplicate on a new VM using 9.3.

Based on issues others have noted running Debian with Gnome in VirtualBox , I have enabled 3D acceleration in VirtualBox settings.

How can I debug and hopefully solve this extraordinarily high gnome-shell CPU usage from a single action?

EDIT: This issue is duplicated by entering vscode into "fullscreen mode." EDIT2: This issue is duplicated by entering ANY app into "fullscreen mode" with f11.

EDIT3: This issue is likely the same as this one related to virtualbox not handling x11 right. I will test tonight by disabling 3d acceleration and seeing what happens. Annoyingly, I enabled 3d accelerations to improve input lag issues...


This is most likely because VirtualBox cannot handle 3d acceleration for x11 guests.

https://www.virtualbox.org/wiki/X11Guest3D https://askubuntu.com/questions/1035410/ubuntu-18-04-gnome-hangs-on-virtualbox-with-3d-acceleration-enabled

Disabling 3d acceleration fixes the issue, but increases input lag to unacceptable levels.

I have not managed to get gnome-wayland working (this thread indicates it requires esoteric fiddling with nvidia drivers), and the commands in this thread seem to indicate I am using gnome x11. I have also not managed to get another environment working to an acceptable level.

I will leave this answer as unaccepted in the hopes someone can point me in a desirable solution. If that doesn't happen, I'll have to accept this answer as basically "You must either have bad input lag and functional full screen, or only kinda bad input lag and non-functional full screen."

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.