0

I have a sabresd based reference board and I have ported android O from official source. I am facing a problem that none of the service works. All are getting killed. In my case adb is not present as there is no usb port below I am pasting the logs

android:/ $ mount -o remount,rw /system /system
mount: '/system' not in /proc/mounts


cat /proc/mounts
rootfs / rootfs ro,seclabel 0 0
tmpfs /dev tmpfs rw,seclabel,nosuid,relatime,mode=755 0 0
devpts /dev/pts devpts rw,seclabel,relatime,mode=600,ptmxmode=000 0 0
proc /proc proc rw,relatime 0 0
sysfs /sys sysfs rw,seclabel,relatime 0 0
selinuxfs /sys/fs/selinux selinuxfs rw,relatime 0 0
none /sys/kernel/debug debugfs rw,seclabel,relatime,mode=755 0 0
tmpfs /mnt tmpfs rw,seclabel,relatime,mode=755,gid=1000 0 0
none /config configfs rw,relatime 0 0
/dev/block/by-name/system /system ext4 ro,seclabel,relatime,data=ordered 0 0
/dev/block/by-name/userdata /data ext4 rw,seclabel,nosuid,nodev,noatime,nodiratime,noauto_da_alloc,errors=panic,data=ordered 0 0
/dev/block/by-name/cache /cache ext4 rw,seclabel,nosuid,nodev,noatime,data=ordered 0 0
/dev/block/by-name/vendor /vendor ext4 ro,seclabel,relatime,data=ordered 0 0
tmpfs /storage tmpfs rw,seclabel,relatime,mode=755,gid=1000 0 0

android:/ # [   16.808715] init: Untracked pid 1691 exited with status 0
[   16.821319] init: Service 'surfaceflinger' (pid 1556) killed by signal 6
[   16.828228] init: Sending signal 9 to service 'surfaceflinger' (pid 1556) process group...
[   16.836866] init: Failed to open process cgroup uid 1000 pid 1556: No such file or directory
[   16.845413] init: Error encountered killing process cgroup uid 1000 pid 1556: No such file or directory
[   16.855234] init: Sending signal 9 to service 'zygote' (pid 1539) process group...
[   16.862946] init: Failed to open process cgroup uid 0 pid 1539: No such file or directory


mount -o rw,remount /system >>>>>this works

[  174.751226] EXT4-fs (mmcblk0p3): re-mounted. Opts: data=ordered

I tried various commands such as

chmod 777 /system/build.prop
mount -o rw,remount /system  >>> this works but still no use
mount -o remount,rw /system /system
mount -o ro,remount /system
mount -o rw,remount /userdata
mount -o rw,remount /mnt/sdcard
mount -o rw,remount /dev/block/mmcblk0p10 /userdata

I get this error on trying to mount userdata

mount: '/userdata' not in /proc/mounts

Can any one help me, what is wrong here? I tried

sudo chmod -R -v 777 *

No use still I get

[  452.171977] init: Sending signal 9 to service 'memtrack-hal-1-0' (pid 4986) process group...
[  457.130689] init: Service 'camera-provider-2-4' (pid 5022) exited with status 1
[  457.138182] init: Sending signal 9 to service 'camera-provider-2-4' (pid 5022) process group...
[  457.147345] init: Failed to open process cgroup uid 1047 pid 5022: No such file or directory
[  457.155878] init: Error encountered killing process cgroup uid 1047 pid 5022: No such file or directory
[  457.165819] init: Service 'memtrack-hal-1-0' (pid 5023) exited with status 1
[  457.172917] init: Sending signal 9 to service 'memtrack-hal-1-0' (pid 5023) process group...
[  457.181558] init: Failed to open process cgroup uid 1000 pid 5023: No such file or directory
[  457.190096] init: Error encountered killing process cgroup uid 1000 pid 5023: No such file or directory
[  457.200562] init: starting service 'sensors-hal-1-0'...
[  457.206909] init: Failed to make and chown /acct/uid_1000: Read-only file system

    android:/system # [  462.139204] init: Service 'memtrack-hal-1-0' (pid 5060) exited with status 1
    [  462.146367] init: Sending signal 9 to service 'memtrack-hal-1-0' (pid 5060) process group...
    [  462.155227] init: Failed to open process cgroup uid 1000 pid 5060: No such file or directory
    [  462.163740] init: Error encountered killing process cgroup uid 1000 pid 5060: No such file or directory
    [  462.206827] init: starting service 'sensors-hal-1-0'...
    [  462.213089] init: Failed to make and chown /acct/uid_1000: Read-only file system
    [  462.220715] init: createProcessGroup(1000, 5061) failed for service 'sensors-hal-1-0': Read-only file system
    [  462.230803] init: property_set("ro.boottime.sensors-hal-1-0", "462198688721") failed: property already set
    [  462.241315] init: starting service 'surfaceflinger'...

On doing

    android:/dev/block # ls -l
    total 0
    lrwxrwxrwx 1 root root       67 1970-01-01 00:00 by-name -> /dev/block/platform/soc0/soc/2100000.aips-bus/2190000.usdhc/by-name
    brw------- 1 root root 179,   0 1970-01-01 00:00 mmcblk0
    brw------- 1 root root 179,   1 1970-01-01 00:00 mmcblk0p1
    brw------- 1 root root 259,   2 1970-01-01 00:00 mmcblk0p10
    brw------- 1 root root 259,   3 1970-01-01 00:00 mmcblk0p11
    brw------- 1 root root 179,   2 1970-01-01 00:00 mmcblk0p2
    brw------- 1 root root 179,   3 1970-01-01 00:00 mmcblk0p3
    brw------- 1 root root 179,   4 1970-01-01 00:00 mmcblk0p4
    brw------- 1 root root 179,   5 1970-01-01 00:00 mmcblk0p5
    brw------- 1 root root 179,   6 1970-01-01 00:00 mmcblk0p6
    brw------- 1 root root 179,   7 1970-01-01 00:00 mmcblk0p7
    brw------- 1 root root 259,   0 1970-01-01 00:00 mmcblk0p8
    brw------- 1 root root 259,   1 1970-01-01 00:00 mmcblk0p9
    brw------- 1 root root 179,  32 1970-01-01 00:00 mmcblk2
    brw------- 1 root root 179,  40 1970-01-01 00:00 mmcblk2boot0
    brw------- 1 root root 179,  48 1970-01-01 00:00 mmcblk2boot1
    brw------- 1 root root 179,  33 1970-01-01 00:00 mmcblk2p1
    brw------- 1 root root 179,  34 1970-01-01 00:00 mmcblk2p2
    brw------- 1 root root 179,  56 1970-01-01 00:00 mmcblk2rpmb
    drwxr-xr-x 3 root root       60 1970-01-01 00:00 platform
    brw------- 1 root root   1,   0 1970-01-01 00:00 ram0
    brw------- 1 root root   1,   1 1970-01-01 00:00 ram1
    brw------- 1 root root   1,  10 1970-01-01 00:00 ram10
    brw------- 1 root root   1,  11 1970-01-01 00:00 ram11
    brw------- 1 root root   1,  12 1970-01-01 00:00 ram12
    brw------- 1 root root   1,  13 1970-01-01 00:00 ram13
    brw------- 1 root root   1,  14 1970-01-01 00:00 ram14
    brw------- 1 root root   1,  15 1970-01-01 00:00 ram15
    brw------- 1 root root   1,   2 1970-01-01 00:00 ram2
    brw------- 1 root root   1,   3 1970-01-01 00:00 ram3
    brw------- 1 root root   1,   4 1970-01-01 00:00 ram4
    brw------- 1 root root   1,   5 1970-01-01 00:00 ram5
    brw------- 1 root root   1,   6 1970-01-01 00:00 ram6
    brw------- 1 root root   1,   7 1970-01-01 00:00 ram7
    brw------- 1 root root   1,   8 1970-01-01 00:00 ram8
    brw------- 1 root root   1,   9 1970-01-01 00:00 ram9
    drwx------ 2 root root       60 1970-01-01 00:00 vold
    brw------- 1 root root 254,   0 1970-01-01 00:00 zram0

I do not understand even after giving all permissions I am getting read only errors.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.