I have bought a HP Probook x360 11 G1 EE laptop with an EFI boot and Windows preinstalled.

The first problem is that there's no option in the bios to support legacy boot, so I can't do without EFI.

Then, I tried EasyBCD to install linux, but EasyBCD says that it cannot install Linux.

So, I tried Grub2Win, but when "testing to boot" into grub, the system just hangs at boot with a black screen and a blinking cursor on the top left of the screen.

I'm pretty sure that if I just let some live Linux usb modify the master boot record, even Windows will not be able to boot anymore - I don't want to try that.

What can I do to boot Linux? What is this new kind of EFI boot that seems to be locked to Windows only?

  • 1
    Not an answer, I'm afraid, but take a read through lists.gnu.org/archive/html/bug-grub/2017-12/msg00010.html and see if any of that helps. – roaima Jul 23 '18 at 16:14
  • @roaima Thanks a lot for this interesting link ! No way out of my problem, but the author tracked the issue down to a grub issue... Very interesting ! I wonder whether some syslinux2win program does not exist ? :-) Thanks – xtof54 Jul 23 '18 at 18:13
  • Without additional information, this sounds like a secure boot issue. When configured properly (usually by the hardware manufacture), secure boot will prevent any attempt to boot a different operating system (usually Windows is preinstalled, and is the only blessed boot image). You should be able to go into the BIOS and disable secure boot. – GracefulRestart Jul 23 '18 at 20:37
  • @GracefulRestart nope sorry, secure boot has been disabled long ago :-) But thanks for the reply. I'm afraid the issue is way deeper into the interaction between EFI and grub. All this is so sad for linux because this kinds of unfair limitations will have a strong impact on people who may be willing to try linux, but will just abandon because of the risks to lose everything... :-( – xtof54 Jul 24 '18 at 20:13

Depending on what exactly you've tried, the problem might be not EFI per se, but Secure Boot. It is another feature on top of EFI.

Most major distributions already include an installation procedure that can deal with Secure Boot, usually by using a Microsoft-signed "shim" pre-bootloader that allows loading the real bootloader. A notable exception is Debian: the reason is Debian has very strict principles of Free Software, and Secure Boot can be at odds with those principles, depending on how it's been implemented.

Minor distributions, on the other hand, may or may not require disabling Secure Boot before they can be installed... although more and more of those distributions are simply copying the EFI and Secure Boot solutions of their "parent" major distribution (if one exists).

Another source of problems might be that although the system has a 64-bit processor, the EFI firmware might be using 32-bit code. This might be most common in systems whose maximum RAM capacity is limited to 4 gigabytes or less. This is another thing the installers of some Linux distributions might not yet be capable of detecting and dealing with automatically.

| improve this answer | |
  • Thank you, but no, secure boot was bios-disabled. – xtof54 Sep 26 '18 at 17:15

I'm not 100% sure what exactly was the problem, but a cross-post on superuser (sorry about not linking before):


gave me some hint to investigate, and I finally managed to install ubuntu, although I had to manually stop the auto-install script of ubuntu at some point, and then finalize the installation process manually by editing the config files in the efi partition.

So it's really an issue with the ubuntu installer and that very specific hardware: I have confirmed this because several friends of my son had the same issue with their own laptop, which was exactly the same because it was a common selling campaign organized by their school, and I had to replicate the very same process on several of their laptops, and only managed this way to install ubuntu; otherwise, all of them were failing all of their install, whatever linux iso they tried. :-/

| improve this answer | |
  • Just to satisfy my curiosity, and perhaps to help others with the same problem: Could you please describe in detail the configuration change you had to make? – telcoM Oct 16 '18 at 18:06
  • Sorry, I didn't noted down the modifications I did, and now that it's working, I can't reproduce any more ;-) I just remember I had to modify the boot config under the Microsoft directory in the EFI partition to add into it another loader that is compatible with linux - this is documented elsewhere on the internet, and I think the Ubuntu installer should have done it by itself, but for some reason, didn't. – xtof54 Oct 22 '18 at 6:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.