Using KDE5 on Arch Linux with Wayland. I hit apply when changing resolutions to see which one would be suitable, small desktop resolution and then my monitor said it was unsupported.

How do I revert/reset it from a terminal?

  • 1
    Found this cli tool that does it - reddit.com/r/linux/comments/6bj8lk/… (untested) – slm Jul 23 '18 at 0:44
  • That doesn't work with KDE. Service unavailable; the name org.gnome.Mutter.DisplayConfig was not provided by any service files. – Enkouyami Jul 23 '18 at 7:23
  • Sorry about that, I missed you were on KDE, that's a GNOME solution. – slm Jul 23 '18 at 7:24
  • Also, renaming the kde4 folder doesn't fix it: mv ~/.kde4 ~/.kde4.old – Enkouyami Jul 23 '18 at 7:37
  • I could find nothing that shows how to do this, very perplexing, and I do not have any of this locally to try. – slm Jul 23 '18 at 7:38

This isn't a CLI solution:

  1. Make sure the user in question is logged off (CTRL + Alt + Del, then enter)
  2. Go to a TTY terminal, login as that user,
  3. Run mv ~/.kde4 ~/.kde4.old then startx
  4. Go back to the main display (CTRL + Alt+ F7), login, and it should display the default resolution.
  5. Close the x session
  6. Open the display settings from the system settings (systemsettings5).
  7. Reset the settings, select enable the main display, then click apply.
  8. Go to any terminal and enter mv ~/.kde4.old ~/.kde4
  9. Reset the display settings again then click on apply or OK.
  • Renaming the ~/.kde4 folder then restarting, on paper, seemed to be the solution, but without all of these other steps, it didn't work. – Enkouyami Jul 23 '18 at 8:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.