I found several posts on this, but none of them work.

When I do yum update, I get the error thread.error: can't start new thread; full stacktrace follows:

[root@ripper234 ~]# yum update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 178, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 345, in doCommands
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 101, in _getTs
  File "/usr/lib/python2.4/site-packages/yum/depsolve.py", line 112, in _getTsInfo
    pkgSack = self.pkgSack
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 661, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 501, in _getSacks
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 232, in populateSack
  File "/usr/lib/python2.4/site-packages/yum/repos.py", line 79, in doSetup
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 179, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/fastestmirror.py", line 181, in postreposetup_hook
    all_urls = FastestMirror(all_urls).get_mirrorlist()
  File "/usr/lib/yum-plugins/fastestmirror.py", line 333, in get_mirrorlist
  File "/usr/lib/yum-plugins/fastestmirror.py", line 376, in _poll_mirrors
  File "/usr/lib/python2.4/threading.py", line 416, in start
    _start_new_thread(self.__bootstrap, ())
thread.error: can't start new thread

I've already tried yum clean, that didn't help.

My OS is Centos 5.5.

  • 1
    Looks pretty much like python problem. Why don't you post this to yum bugtracker?
    – alex
    Dec 6 '10 at 19:57
  • I've gotten this error when I ran out of memory on a small (64M) VM.
    – user2267
    Mar 26 '11 at 15:42
  • @barrycarter - me too.
    – ripper234
    Mar 27 '11 at 22:09

This is mostly an issue with yum in CentOS 5.5+ versions and is caused by the fastestmirror plugin. One way to bypass is to use yum update --disableplugin=fastestmirror.

The best method to use rather than disabling the plugin completely is to reduce the number of threads. To this just edit the /etc/yum/pluginconf.d/fastestmirror.conf file and change the value maxthreads=xx to a lower value.

My default values were 15 and was giving an error with 150MB+ free RAM; I changed it to 5 and no more troubles.


You could try to disable fastestmirror plugin and check if after that change yum will be working properly. To disable it do: edit /etc/yum/pluginconf.d/fastestmirror.conf and change enabled = 1 to 0 or just remove plugin package: yum remove yum-fastestmirror or yum remove yum-plugin-fastestmirror.

  • is that a typo? didn't you mean remove instead of install? Nov 16 '14 at 15:03
  • Yup. It was typo. Fixed now.
    – pbm
    Nov 17 '14 at 13:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.