2

https://bindfs.org/docs/bindfs.1.html

-u, --force-user, -o force-user=...

Makes all files owned by the specified user. Also causes chown on the mounted filesystem to always fail.

http://man7.org/linux/man-pages/man8/mount.fuse.8.html

uid=N Override the st_uid field set by the filesystem (N is numeric).

2 Answers 2

1

uid=N is not very user-friendly. Normally people want to specify the name of the user, which is supported by force-user.

I'm not sure this is the answer. For other filesystems like vfat, the uid mount option is automatically resolved from a name to a number by the mount command. Maybe when it runs a separate helper like mount.fuse, the mount options are passed directly and the user name is not looked up, but I don't know.

Though I also wonder if the FUSE manpage is written incorrectly and uid=sourcejedi works as a mount option, but it wouldn't work if you run the bindfs command directly with -o uid=sourcejedi.

0

I have confirmed that uid=N only works with the uid number not the uid= probably newer version may have some ways to defined fuse.

1
  • which command(s) did you use? mount, mount.fuse, bindfs, ... ?
    – sourcejedi
    Oct 25, 2018 at 14:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .