0

I have just installed gnome user interface on my CentOS 7 but didn't install gnome terminal. Now there isn't any other app installed than nautilus file manager and control-center. What do I do?

  • How did you install GNOME? – Ignacio Vazquez-Abrams Jul 22 '18 at 6:24
  • CentOS minimal installation is CLI by default. I installed gnome with the commands # yum groupinstall "X Window System" # yum install gnome-classic-session # unlink /etc/systemd/system/default.target # ln -sf /lib/systemd/system/graphical.target /etc/systemd/system/default.target – user301736 Jul 22 '18 at 6:28
  • Check with this command : rpm -qa | grep gnome-terminal. You need to switch text mode and run yum install gnome-terminal. – supriady Jul 22 '18 at 6:29
  • @supriady do you mean I can switch back – user301736 Jul 22 '18 at 6:44
  • you can switch graphical mode or text mode. find /etc/inittab and read it. Using systemctl to switch it.multi-user.target or graphical.target. – supriady Jul 22 '18 at 6:57
1

If you started with the minimal installation of CentOS 7 you need to do the following to enable the Desktop:

$ sudo yum groupinstall "GNOME Desktop" "Graphical Administration Tools"

Then set the default run level to 5 (X windows)

$ sudo ln -sf /lib/systemd/system/runlevel5.target \
   /etc/systemd/system/default.target

This step can be done more succinctly using systemd:

$ sudo systemctl set-default graphical.target 

Then reboot.

What if I'm locked in GNOME?

If you're somehow logged into GNOME desktop but find yourself unable to get to a gnome-terminal or any terminal for that matter, you can always reboot the system into runlevel 3 (multi-user with networking, no desktop).

While at the GRUB prompt, edit the kernel entry that's going to boot by hitting the letter e. Then go to the line that starts with the string linux and go to the end of this line and type the number 3.

   ss1    ss2

NOTE: Then hit F10 or Ctrl + X.

From this point you'll be able to log into your system in console mode, run your yum commands to install what I mentioned above and then reboot the system.

References

  • @QuantumK - if you're somehow stuck in X without the ability to access a terminal, reboot the system and switch to run level 3 (console) and login and do the yum installs I'm telling you in this answer, then reboot back into X and you'll have gnome-terminal. – slm Jul 22 '18 at 6:58
  • Do you mean from grub's option menuThere's only option to boot into the OS or use a rescue version. – user301736 Jul 22 '18 at 7:06
  • @QuantumK - see my updates, you can hit the e key to enter GRUBs edit menu and change the runlevel. – slm Jul 22 '18 at 7:12
  • @QuantumK - np, the hidden menus always thwart ppl until someone else enlightens you to their existence 8-). If you're good, please mark this as accepted so other's know your issue's been resolved. – slm Jul 22 '18 at 7:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy