5

There seem to be similar questions here, here and here but with no confirmed answer, and no answer that addresses my situation satisfactorily.

Update: I've deleted Windows and reset BIOS factory settings and the problem persists. This is no longer a dual-boot specific question and has been updated.

I'm trying to install Linux Mint on a Dell XPS 13 9350 with no installed Hard Drive. I also tried Ubuntu with the same results, but I'll talk specifically about Mint in this question as its my desired distro.

I have added Mint to an 8GB USB stick via Yumi. I reboot the machine and hold down F12, then choose to boot from the USB.

A second screen allows me to "Start" Linux. I start it, and then begin installing from the install icon on the desktop. After being asked about language, keyboard and WiFi I'm told that I only have 10GB of space, which is not enough to install. It appears to be trying to install on the USB drive, as this is a 256GB hard drive.

Output of lsblk -f:

NAME        FSTYPE   LABEL                          UUID                      MOUNTPOINT
loop0       iso966   Linux Mint 19 Cinnamon 64-bit  2018-06-26-15-38-36-00    /cdrom
loop1       squashfs                                                          /rofs
sda                                                                        
Lsda1      vfat     MULTIBOOT                      190...                    /isodevice
nvme0n1
Lnvme0n1p1 ext4                                    16639...

I have manually toggled "RAID On" to AHCI in the BIOS and that allowed me to complete the Linux install wizard, but gave me a Dell Support window message on boot about a missing OS. Since then I have reset to factory BIOS settings and I get a "Missing Hard Drive" message on boot.

What can I do to both install and boot up Mint, now on a computer with no OS?

7
  • 2
    @dsstorefile1 I have. None of my volumes are dynamic though. I added that to my answer
    – steel
    Jul 22, 2018 at 13:22
  • There's an answered question here that applies to some Dell XPS 13: unix.stackexchange.com/questions/328687/…
    – sourcejedi
    Jul 22, 2018 at 17:32
  • @sourcejedi I saw that. I just set it from RAID On to AHCI and while it allows me to install Linux, now the computer won't boot up except from the USB drive. It says it can't find an OS. Not sure if this is answers the question.
    – steel
    Jul 22, 2018 at 18:30
  • @sourcejedi neither. I changed to AHCI and installed Mint and erased Windows. So I seem to have gotten myself into a new problem, which may require a new question if I can't get myself out.
    – steel
    Jul 22, 2018 at 19:43
  • 1
    Please add the output of lsblk -f so we can see the drives and partitions you're working with. The screenshot you mentioned in an earlier comment is missing.
    – Mio Rin
    Jul 24, 2018 at 13:20

3 Answers 3

5

I was able to solve this with the help of a colleague, finally. It took several steps in BIOS:

  1. Disable Secure Boot.
  2. Set SATA-controller to AHCI from RAID On.
  3. Set boot mode to legacy from UEFI.

I wasn't able to figure out exactly what was wrong, but the installer seems to have installed the OS in a drive that UEFI did not auto-detect, but legacy boot mode did.

2
  • 2
    this last answer by steel worked for me too, even without the option #3 (I'm working with a Dell XPS 13 (7390) and it does not support anymore Legacy mode on boot.
    – salb
    Feb 11, 2020 at 1:50
  • 2
    Thank you for confirming #2 for me. Please note, you do not need to necessarily modify to legacy from UEFI. But Disabling Secure Boot will find the flash drive, Setting "RAID On" to AHCI will make the partitions/drive detectable.
    – TheFrack
    Dec 10, 2020 at 22:50
2

Your bootloader/EFI partition is on /dev/sda while the computer is most likely looking for it on /dev/nvme0. (I have had a laptop that was hard-coded to boot from the internal SSD before)

You need to move or create it onto the nvme device to get it to boot properly.

A reinstallation, where you select manual partitioning, would be the easiest way.

This article has information on how the EFI partition should be for it to work properly.

2
  • sda looks like the live-USB actually. It would be possible to boot with just a single partition, but of course that implies not using EFI, which is a bit odd.
    – sourcejedi
    Jul 25, 2018 at 7:45
  • @mioriin, A reinstallation of what? My issue is that I have no OS and cannot install from the USB.
    – steel
    Jul 25, 2018 at 14:07
1

Idea #1

According to the ArchLinux Wiki with respect to this laptop (Dell XPS 13 (9350)):

When the SATA-controller is set to RAID On in Bios, the hard disk (at least the SSD) is not recognized. Set to Off or AHCI (AHCI is recommended) before attempting to install Arch.

Idea #2

In the section below that, NVM Express SSD, there's guidances on how to get the SSD to be detected properly during boot/installation:

The location of the nvme module for "NVM Express" SSD has changed between linux kernel version 4.3 and 4.4. If you experience "cannot find root device" on boot, it may be due to the nvme module not being present in initramfs. In this case, the following may resolve your issue.

Edit your /etc/mkinitcpio.conf file:

  ...
   MODULES=(... "nvme")
   ...

Then update the bootloader.

  # mkinitcpio -p linux

where linux is the name of the image loaded on boot. If you installed linux-mainlineAUR then change that to linux-mainline.

Idea #3

There's also this thread, titled: Grub and NVMe device that discusses a booting issue with this laptop, GRUB, and NVMe HDD's.

However, trying to boot using the freshly installed grub instance, I get the error "no such device: " I've checked, the UUIDs, the one given in the error message matches the UUID of /boot, so the configuration of the boot partition at least is as expe

The workaround is mentioned in that same thread, basically use a different boot loader.

References

10
  • Thanks for the response. In my question I noted that I toggled RAID off and AHCI on with consequences. Maybe you could explain what that looks like to do correctly? That is part of the requirement stated for the bounty.
    – steel
    Jul 25, 2018 at 13:39
  • I have no access to this particular type of laptop so cannot really show exact steps. I saw the requirement, was looking through backlog of Q's was trying to provide assistance. Did you try a different distro to see if it was just Mint's particulars?
    – slm
    Jul 25, 2018 at 13:47
  • I tried Ubuntu with the same results.
    – steel
    Jul 25, 2018 at 13:51
  • @steel certification.ubuntu.com/hardware/201508-18805 shows that you need the latest firmware but this h/w should be supported.
    – slm
    Jul 25, 2018 at 14:15
  • 1
    @steel - I believe you have to create it.
    – slm
    Jul 26, 2018 at 17:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .