4

I'm using a dark theme in Debian, but the Dolphin file manager just ignores it.

I have seen some examples of a dark theme in Dolphin, but I can't find a way to do it. I've seen some ways to set a background image, but of course that doesn't help me, because I would have black text on black background.

From what I've seen I might need a KDE theme. I have found this, but it gives me a .qtcurve file.
I looked up how to use it and this page told me to use KDE system settings. Sounds weird, but ok, I installed the systemsettings package.
But in the KDE system settings I only had the categories "shortcuts", "network settings" and "network connectivity". So I installed kde-config-gtk-style and it did indeed add the "application style" category to the KDE settings.
There I first tried setting "BlackMATE" as the GTK2 and GTK3 theme, which did nothing. Then I tried importing the downloaded theme file, which didn't work, because it expected a .tar file.
So I packed the theme file into a .tar archive (which seems weird, why would I need to do that?) and imported that, which made the settings window become unresponsive and then close itself. I guess it's not the sort of tar file it expects?
When I click "download GTK2 themes" or "download GTK3 themes", it stays at "initialising" and does nothing.

So how do I set a dark theme in Dolphin? Do I even need the KDE settings?

Debian 9.5
Cinnamon 3.2.7
Dolphin 16.08.3

1
  • Great, Google sent me back to my own question. Since asking this question, I switched to Manjaro, using the Mate desktop environment. I can use the program "qt5ct" to switch most of Dolphin to a dark theme, but not the background of the are with all the folders and files, which is of course the most important thing. Commented Feb 10, 2020 at 16:24

4 Answers 4

7

I recently switched from Debian to Manjaro and from Cinnamon to Mate, but this solution should hopefully apply to all distributions and desktop environments:

Firstly, the program "qt5ct" can be used to edit the theme of programs using Qt themes instead of whatever Cinnamon, Mate, etc. use. On Manjaro I installed it with yay qt5ct, on Debian it's probably sudo apt-get install qt5ct. I selected an arbitrary dark theme ("style") in there.

But that doesn't change the background image, that is still white. So I found this answer on AskUbuntu. It's pretty long, but what matters, if you just want a black background, is:

  • Create a file somewhere that contains a custom Qt style sheet, with this content:
DolphinViewContainer > DolphinView > QAbstractScrollArea {
      background-color: black;
}
  • Start Dolphin like this in the future: dolphin -stylesheet /path/to/style_sheet.qss
6
  • it's yay -S qt5ct in arch and manjaro you forget -S and worked for me thanks.
    – sam nikzad
    Commented Jun 10, 2020 at 15:57
  • Just yay search_term gives a list of possible packages. Since you can often choose between the default package, the Git version, older version, differently packaged ones, etc., I find it useful to always open the menu, even if you know the package name. Of course in a script you would use pacman directly or something else, but this is not a script usecase. Commented Jul 1, 2020 at 14:44
  • BTW, I switched from Mate to KDE after I wrote this answer and there it simply uses the system theme, even for the background colour, no special treatment required. Commented Jul 1, 2020 at 14:45
  • i was switched to Thunar filemanager from dolphin in archlinux with xfce4 desktop
    – sam nikzad
    Commented Jul 1, 2020 at 17:44
  • I don't know what you mean with "I was switched", but you can just install and use Dolphin if you prefer that. It's mostly independent of the desktop environment. Commented Jul 1, 2020 at 20:27
4

Go to the ~/.config/kdeglobals and add these lines

[Colors:View] BackgroundNormal=94, 104, 109

the numbers representing the RGB value of whatever color you choose.

3
  • Your solution worked for me. But is there a way to also change text color to white ? I mean, if I make my foreground black (and not only grey like in your example), I will be unable to read text. Commented Mar 23, 2021 at 15:46
  • Thanks, working for my in MX Linux 19 with openbox (using the Breeze Dark Theme inside the package Breeze) Commented Jul 22, 2021 at 22:41
  • thanks. works on ubuntu 22.04
    – acgbox
    Commented Feb 18 at 3:16
2

I'm using a dark theme and it simply applies to Dolphin as well.

I just tested it out again and I did notice that after switching from light to dark again, I had to close the running Dolphin instance and start a new one to have the dark theme take effect. But I guess you tried that already..?

Btw, I use the Breeze Dark theme: Breeze Dark theme

You can find this setting under KDE's System Settings > Appearance > Workspace theme > Look and Feel enter image description here Maybe it is a bug in that KDE version or debian release, did you try testing out the latest version (in a virtual machine)? I'm on Dolphin 17.04.2.

10
  • 1
    My Dolphin version is 16.08.3 and Synaptic (and apt-get) doesn't find any updates for it. My settings have the categories "Startup", "View modes", "Navigation", "Services", "Trash" and "General", also there are less buttons at the bottom. Since I didn't really write that into the question, my Debian version is 9.5. Commented Oct 2, 2018 at 19:28
  • The setting I showed is in the KDE System Settings. I updated the answer to explain where to find it. In your question you mention the categories you have in your System Settings but Workspace Theme does not seem present. Maybe you have to install a package to have the workspace theme settings?
    – mx1up
    Commented Oct 2, 2018 at 20:01
  • btw, I looked up: the workspace settings are in the package `plasma-workspace', for debian stretch I found a package here: packages.debian.org/stretch/plasma-workspace . The dark theme itself (I'm using), is contained in breeze5-style, for debian, that seems to be packages.debian.org/stretch/breeze
    – mx1up
    Commented Oct 2, 2018 at 20:08
  • I installed plasma-workspace and it does add a few more menus, but not that one. I have now: "Application style", "Desktop behaviour", "Shortcuts", "Applications", "Settings", "Connectivity", "Power management". Commented Oct 2, 2018 at 22:51
  • I looked up the file to be responsible for the "Workspace Theme" settings: settings-appearance-workspacetheme.desktop. This file is contained in the systemsettings package: packages.debian.org/stretch/amd64/systemsettings/filelist . Do you have this one installed?
    – mx1up
    Commented Oct 3, 2018 at 10:10
0

If you start Dolphin with the stylesheet containing

DolphinViewContainer > DolphinView > QAbstractScrollArea {
      background-color: black;
    }

you will lose almost all the file icons. The files are displayed with their names only, without the fancy icons. Of course, this will happen if you are not using Gnome as your desktop environment but, for example, xfce. To remedy this, make sure an icon theme is set in qt5ct.

1
  • 1
    This would be better as an edit to my answer. Also, the icons are not definitely gone, only if the theme doesn't work properly. Commented Sep 7, 2020 at 22:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .