2

I'm using Gnome desktop environment on Debian 9.5, my laptop is Acer Aspire V5 series.

I usually cycle through three keyboard languages during the day: English, Italian and Spanish. The first two layouts work perfectly, but just today I realize that the Spanish layout is giving me quotation marks when it should give me accented characters. For instance:

' then e, should produce " é ", but it is giving me " ´e " instead.

I've been using this version of Debian and Gnome Desktop since a year ago, and I never had this problem before. This week I had an apt upgrade of the system, so I suspect that action unleashed the problem. I wonder if it is a bug of the latest updated software or maybe that the firmware of my keyboard needs to be updated.

Please, if there is anyone out there having the same problem I would like some hints on how can it be fixed.

EDIT 1

This fellow had the same problem two years ago, but unfortunately his question was never answered: Accented characters stopped working on French Canadian keyboard.

  • This thread suggests two things: 1) run the script in the thread and see what compose options you have 2) Open System Menu --> Preferences --> Keyboard Layout --> Layouts tab --> Select your layout --> Options --> Compose key. This debian manual page suggests dpkg-reconfigure keyboard-configuration or dpkg-reconfigure console-setup, and make sure the settings are reasonable. – Nick ODell Jul 21 '18 at 6:19
  • @roaima, So this is being reopened, so that it can be closed as a dupe? Shouldn't that be a mod flag? – Stephen Rauch Jul 21 '18 at 13:02
  • @roaima - I reopened this. – slm Jul 21 '18 at 15:31
  • @StephenRauch - I reopened this. – slm Jul 21 '18 at 15:31
  • 1
    If you'd like you can move your solution from the Q to an A'er and then mark yours as accepted. I cleaned up the edits so it should be just a copy/paste job. – slm Jul 21 '18 at 15:32
3

After some Google searching I found that my old method for input accented characters is known as dead keys, there are other methods like compose key; as it is suggested in this: [SOLVED] keyboard entry of "accented" characters - (thank you Nick ODell).

After trying every possible solution I discovered that the input methods were not working on gedit, terminal and evolution, but they did in Libre Office. So I went to tackle the problem on GTK by Google searching again and I found this: Dead keys suddenly stopped working in GTK applications.

I gave a try to apt-get install ibus and that solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.