8

I am trying to use Xorg instead of Wayland on my Arch Linux.

I have two graphics cards in my laptop. An Intel and a Nvidia graphics card.

The output of my log file is:

[    53.401] (WW) Failed to open protocol names file lib/xorg/protocol.txt
[    53.403] 
X.Org X Server 1.20.0
X Protocol Version 11, Revision 0
[    53.403] Build Operating System: Linux Arch Linux
[    53.403] Current Operating System: Linux thinkpad 4.17.8-1-ARCH #1 SMP PREEMPT Wed Jul 18 09:56:24 UTC 2018 x86_64
[    53.403] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=4c4cf377-77af-4cd1-bd40-6d94fae4e2f1 rw quiet resume=UUID=4a1be855-ae3e-4add-b3e0-3b3abb817115 nvidia-drm.modeset=1
[    53.403] Build Date: 18 June 2018  03:12:37PM
[    53.403]  
[    53.403] Current version of pixman: 0.34.0
[    53.404]    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[    53.404] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    53.404] (==) Log file: "/home/henzler/.local/share/xorg/Xorg.1.log", Time: Fri Jul 20 17:30:51 2018
[    53.412] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    53.412] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    53.414] (==) No Layout section.  Using the first Screen section.
[    53.414] (==) No screen section available. Using defaults.
[    53.414] (**) |-->Screen "Default Screen Section" (0)
[    53.414] (**) |   |-->Monitor "<default monitor>"
[    53.415] (==) No device specified for screen "Default Screen Section".
    Using the first device section listed.
[    53.415] (**) |   |-->Device "Intel Graphics"
[    53.415] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
[    53.415] (**) Option "DontZap" "false"
[    53.415] (==) Automatically adding devices
[    53.415] (==) Automatically enabling devices
[    53.415] (==) Automatically adding GPU devices
[    53.415] (==) Automatically binding GPU devices
[    53.415] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    53.415] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[    53.415]    Entry deleted from font path.
[    53.415] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[    53.415]    Entry deleted from font path.
[    53.415] (==) FontPath set to:
    /usr/share/fonts/misc,
    /usr/share/fonts/TTF,
    /usr/share/fonts/100dpi,
    /usr/share/fonts/75dpi
[    53.415] (**) ModulePath set to "/usr/lib/xorg/modules,/usr/lib/nvidia/xorg"
[    53.415] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
[    53.415] (II) Module ABI versions:
[    53.415]    X.Org ANSI C Emulation: 0.4
[    53.415]    X.Org Video Driver: 24.0
[    53.415]    X.Org XInput driver : 24.1
[    53.415]    X.Org Server Extension : 10.0
[    53.416] (++) using VT number 3

[    53.420] (II) systemd-logind: took control of session /org/freedesktop/login1/session/c3
[    53.422] (II) xfree86: Adding drm device (/dev/dri/card0)
[    53.424] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 10 paused 0
[    53.424] (II) xfree86: Adding drm device (/dev/dri/card1)
[    53.425] (II) systemd-logind: got fd for /dev/dri/card1 226:1 fd 11 paused 0
[    53.427] (**) OutputClass "nvidia" ModulePath extended to "/usr/lib/nvidia/xorg,/usr/lib/xorg/modules,/usr/lib/xorg/modules,/usr/lib/nvidia/xorg"
[    53.427] (**) OutputClass "nvidia" setting /dev/dri/card0 as PrimaryGPU
[    53.429] (--) PCI: (0@0:2:0) 8086:191b:17aa:5050 rev 6, Mem @ 0xf0000000/16777216, 0xe0000000/268435456, I/O @ 0x0000e000/64, BIOS @ 0x????????/131072
[    53.429] (--) PCI:*(2@0:0:0) 10de:134d:17aa:5050 rev 162, Mem @ 0xf1000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000d000/128
[    53.429] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    53.430] (II) LoadModule: "glx"
[    53.430] (II) Loading /usr/lib/nvidia/xorg/libglx.so
[    53.495] (II) Module glx: vendor="NVIDIA Corporation"
[    53.495]    compiled for 4.0.2, module version = 1.0.0
[    53.495]    Module class: X.Org Server Extension
[    53.496] (II) NVIDIA GLX Module  396.24  Wed Apr 25 23:17:01 PDT 2018
[    53.497] (II) LoadModule: "intel"
[    53.498] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    53.502] (II) Module intel: vendor="X.Org Foundation"
[    53.502]    compiled for 1.20.0, module version = 2.99.917
[    53.502]    Module class: X.Org Video Driver
[    53.502]    ABI class: X.Org Video Driver, version 24.0
[    53.502] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
    i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
    915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
    Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
    GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[    53.503] (II) intel: Driver for Intel(R) HD Graphics
[    53.503] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[    53.503] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[    53.503] xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
[    53.505] (II) intel(G0): Using Kernel Mode Setting driver: i915, version 1.6.0 20180308
[    53.505] (II) intel(G0): SNA compiled from 2.99.917-831-ge7bfc906
[    53.521] (EE) No devices detected.
[    53.521] (EE) 
Fatal server error:
[    53.521] (EE) no screens found(EE) 
[    53.521] (EE) 
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
[    53.521] (EE) Please also check the log file at "/home/henzler/.local/share/xorg/Xorg.1.log" for additional information.
[    53.521] (EE) 
[    53.539] (EE) Server terminated with error (1). Closing log file.

I know there are many similar questions out there but nothing has worked for me so far.

I have done following:

  • Installed xf86-video-intel
  • Removed xorg.conf
  • Installed CUDA + Nvidia drivers
1
  • What is your actual question? Whilst you have (helpfully) provided your objective, an error log and list of things that you have done, you haven't explicitly stated what the problem is. If you did so, you might get a helpful answer. Commented Feb 23, 2022 at 2:23

2 Answers 2

-1

What is even your objective? Do you want to use the low-power and low-performance Intel graphics, or do you want NVIDIA graphics? You installed CUDA, so I guess you plan on using your NVIDIA GPU anyway, so I'd suggest getting rid of xf86-video-intel.

Then follow the Wiki: https://wiki.archlinux.org/title/NVIDIA_Optimus#Use_NVIDIA_graphics_only

-2
  1. [    53.503] Xorg broken xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
    

    In this error, if you do a search on Google about "Xorg broken xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)", you would probably stumble upon another question from Unix Stack Exchange too, such as xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted) - although it also doesn't have a confirmed answer. The answer there specifies the solution for Linux Mint only.

    If you're not running it as a root user. Then trying it out will probably solve this problem.

  2. [    53.415] (II) The server relies on udev to provide the list of input devices.
     If no devices become available, reconfigure udev or disable AutoAddDevices.
    [    53.521] (EE) No devices detected.
    

    These two log entries are related to each other. This states that if you encounter an error where no devices are available, then maybe try reconfiguring udev or disable AutoAddDevices.

3
  • 3
    This seems like a joke answer... in the first point your answer is to google for the solution, and in the second point you just re-iterate what the error message says. Commented Feb 22, 2022 at 3:44
  • There is already a thread about this error also in unix stackexchange and it is common for the error message to contain the solution. Commented Feb 22, 2022 at 19:48
  • 1
    Just to clarify, SE is a Q&A site, not a forum of threaded messages, so there may be a question (but not a thread) relating to this error already on SE.Unix. If so, and you know what that link is, then why not include a link to that question, in order to save the OP from having to search for it themselves (however, such a link would have probably served better as a comment). WRT to the second point, it would have served better as a comment, under the OP's question, asking them whether they have already performed the suggestions from the error message. Commented Feb 23, 2022 at 1:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .