0

I have a problem with the vim color scheme installation. I did the following:

1) a folder was created ~/.vimrc/colors

2) I put the color definition monokai_pro.vim there

3) I edited the file .vimrc to include the following:

   colo monokai_pro
   syntax on
  • When using bash the color syntax is NOT working.
  • When using vim in byobu the color syntax is working.

The same occurs when I use :colo color_scheme directly in vim. In byobu this is working, but not in bash.

Please note, that in bash I can only select colors which are present in /usr/share/vim/vim80/colors/.

I was copying monokai_pro.vim to the above folder but it is not helping.

Can you somebody explain why?

  • It could be your terminal type setting. Please edit your question and add the output of the echo $TERM command in a bash shell. – Andy Dalton Jul 20 '18 at 15:33
  • yes, you are right. the difference is int terminal type setting: bash -> $ echo $TERM xterm byobu -> $ echo $TERM screen-256color – Michel Jul 23 '18 at 9:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.