Recently downloaded Ubuntu Gamepack via USB flash drive. All went well as far as I know and except for my internet problems all is well. I do not no why, and would like some assistance in troubleshooting the problem.

The system has no problems with connecting to the modem via Firefox when the default gateway is typed into the search tab but it cannot connect to anything else. I tried the ping command but it could not find any of the websites I tried.

The last piece of information I can come up with is the output of the ifconfig command that I ran in the terminal, which I will post below this text.

NOTE: If any extra information is required to troubleshoot feel free to ask for it.

enp2s0    Link encap:Ethernet  HWaddr 4c:cc:6a:8e:47:a1  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::9c55:dc17:7b0a:e526/64 Scope:Link
          RX packets:4552 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1295 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1326711 (1.3 MB)  TX bytes:180836 (180.8 KB)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:42516 errors:0 dropped:0 overruns:0 frame:0
          TX packets:42516 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:3342715 (3.3 MB)  TX bytes:3342715 (3.3 MB)
  • Can you ping an external IP address; eg. ping for google's DNS? If this works, but human addresses don't (eg. ping google.com fails), you have issues with DNS (domain name service; or what converts human names to the real IP addresses). – guiverc Jul 20 '18 at 1:55
  • Did you really come over here to answer the same question again? Daim you are dedicated. If is ping'ed it works. If Google.com is ping'ed it says that Google.com is an unknown host – Philip Vestergaard-laustsen Jul 20 '18 at 2:02
  • What would you recommend doing about my dns issue? – Philip Vestergaard-laustsen Jul 20 '18 at 2:03
  • that proves your internet & lan connection is working, but DNS isn't. A quick fix is to add "nameserver" to the end of the /etc/resolv.conf file. is the ip address for google's DNS; you could use of course your ISP's or another; I use as example (it's easy to remember). This is a quick fix only. – guiverc Jul 20 '18 at 2:04
  • I am not sure what you mean by add : "nameserver" to the end of the /etc/resolv.conf file. Please elaborate – Philip Vestergaard-laustsen Jul 20 '18 at 2:09

First to test your can access external, try


which confirms you are connected and can get external. If this works, but the pinging of google.com failed, it's a DNS issue.

A quick fix is to add


to the end of /etc/resolv.conf. DNS is 'domain name service' & translates human names like google.com into their real ip address (numbers). This however is temporary and won't survive a reboot or networking services restart.

You make the change permanent via adding the nameserver to your NM (network manager) setup. On my Lubuntu 18.10 it's Preferences->Network->DNS and add a "" there.

You could also add dns-addresses to /etc/network/interfaces (you can use other DNS addresses instead of google's i've used as example) as per https://wiki.debian.org/NetworkConfiguration.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.