0

I'm trying to install "kde-services", an extension of the Dolphin file manager. Technically it is already installed, but most of its features aren't working yet.

The list of dependencies includes transcode, but it's not available in Synaptic, so I downloaded it manually.

When trying to install it, I get "Error: Dependency is not satisfiable: libmagickcore-6.q16-2 (>= 8:6.8.8.2)". I solved a bunch of these errors before by installing other packages, but here I'm stuck:

When trying to install "libmagickcore-6.q16-2", I get "Error: Dependency is not satisfiable: imagemagick-common (=8:6.8.9.9-5+deb8u13)".

When trying to install "imagemagick-common", I get "Error: A later version is already installed".

I tried uninstalling imagemagick-common, I tried the "download package" button in the package installer and installing that, I tried some more things, but libmagickcore still complains about imagemagick-common missing, even though it is installed, and imagemagick-common still doesn't want to get installed.

How do I get kde-services to run? A way to automatically install all dependencies would be preferred, maybe I'm missing a package source?

0

You're trying to install a package that is not intended for the exact version of the distribution you're using, and so you're hitting dependency problems. Unfortunately, that's normal. That's part of the reason why different distributions and their different major releases exist: to define what library versions can be expected to be available on each major release.

The Error: Dependency is not satisfiable: imagemagick-common (=8:6.8.9.9-5+deb8u13) message would seem to indicate that the dependency specifically requires a version that is specific to Debian Jessie (= Debian major release 8). A later version is already installed suggests you have either a newer release of Debian or one of the Debian-derivative distributions, with a newer major release of ImageMagick in it.

Since ImageMagick is basically a set of libraries and command line tools, many other programs use parts of it and depend on those parts. Now you're trying to have parts of different versions of ImageMagick on the same system; they won't work together. The package management "knows" that and is trying to stop you from doing that.

In essence, you are effectively trying to make a FrankenDebian. Please don't. Or if you persist, consider yourself warned.

From your other question you mentioned in the comments, it appears you're using "Debian buster/sid". So it's a combination of the current testing release (buster, which is going to be Debian 10 once it becomes stable) and sid which is the unstable release. Mixing in packages that are 2 major releases older is not a good idea: you should find the appropriate replacements within your current release, and then adapt the scripts of kde-services if necessary.

The kde-services seems to be essentially just a collection of shell scripts and .desktop files to provide useful functions. The actual functionality is provided by the tools that are specified as its dependencies.

Of those dependencies, transcode in particular seems problematic: it's apparently been abandoned by its developer, as its website http://www.transcoding.org now only has a single write-up about the care of earbud headphones and nothing else.

Unfortunately the name transcode isn't very googleable, but I found copies of its source code dating back to year 2014 here and a minor fork of it with some typos fixed in 2018 here.

It would probably be best to try and find another transcoding tool from your current distribution, and adapt the kde-services scripts to use it instead.

But if you must, instead of using a package intended for Debian 8, you should get transcode's source code, install any libraries it needs as packages (including the -dev packages for each of those libraries, for source code compilation!) and then compile transcode from source. Then it will use the current versions of any libraries it depends on.

  • So you're telling me that this program is incompatible with my Debian version and that I can't install it without messing up the system? That's too bad, it contains many great features that I want. My specs are here: unix.stackexchange.com/questions/443004/… – Fabian Röling Jul 20 '18 at 7:38
  • I get "error: forbidden" for your link, but I can imagine what it says. – Fabian Röling Jul 20 '18 at 7:40
  • You may need to find another version of kde-services that is compiled for your distribution+version combo, or, in the worst case, compile it from source yourself. It's not impossible, but may be more work than just googling for a package and installing it. – telcoM Jul 20 '18 at 7:42
  • The GitHub page says "specifically for RedHat based OS" and the Wikipedia page of RedHat based OSes doesn't list Debian. So it's incompatible? Butbwhy is it in the extension manager of Dolphin then? – Fabian Röling Jul 20 '18 at 7:58
  • I now asked for support: github.com/geobarrod/KDE-Services/issues/6 – Fabian Röling Jul 20 '18 at 8:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.