2

I run a CentOS 6.3 version of 32 bit VM in the Mac OS machine. I get these info from the terminal,

$ uname -a 
Linux Cloudera-Training-VM-4.1.1.c 2.6.32-279.14.1.el6.i686 #1 SMP Tue Nov 6 21:05:14 UTC 2012 i686 i686 i386 GNU/Linux

$ uname -i
i386

$ cat /etc/issue

CentOS release 6.3 (Final)
Kernel \r on an \m

I would like to install Google Chrome in the VM and I read the instructions from a webpage:

It informs to run the following commands:

$ URL=https://dl.google.com/linux/direct/google-chrome-stable_current_x86_64.rpm

$ sudo yum install -y ${URL}

Later to launch the Google Chrome from the terminal,

$ google-chrome-stable

When I run the sudo yum install -y ${URL} command, I get the output provided below,

Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * base: mirror.dhakacom.com
 * extras: mirror.dhakacom.com
 * updates: mirror.dhakacom.com
http://dl.google.com/linux/chrome/rpm/stable/i386/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: google-chrome. Please verify its path and try again

What is the issue here and how to solve it?

8
$ uname -i
i386

This is a 32-bit system. 32-bit Google Chrome is not updated anymore.

URL=https://dl.google.com/linux/direct/google-chrome-stable_current_x86_64.rpm

This is a 64-bit package.

Alternative Option

Vivaldi browser, relatively new browser, but still regularly updated for 32-bit

  • 1
    I reckon Chromium (compiled or from repos) could still be available. – edmz Jul 19 '18 at 11:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.