13

I'm having an issue mounting a shared NAS drive that is hosted on a Windows 2000 server. This is a drive that I'm certain I have access to, and I frequently access it from a Windows 7 machine and a Windows Server 2008 machine. Now, I'm attempting to mount this drive from a RHEL7 machine, but I'm having some issues.

What I've done:

mkdir /mnt/neededFolder
mount -t cifs //DNS.forMyDrive.stuff/neededFolder /mnt/neededFolder -o username=myUserId,password=myPassword,domain=myDomain

What I expected: I expected to be able to access the folder at /mnt/neededFolder

What actually happened: The error I'm receiving (partially shown in the subject line here) is

mount error(115): Operation now in progress
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

What the log says:

dmesg output:

[1712257.661259] CIFS VFS: Error connecting to socket. Aborting operation.
[1712257.662098] CIFS VFS: cifs_mount failed w/return code = -115

We can all see that there is a connection issue, that is obvious. I know both machines are connected to the network. What can I try next to get this drive mounted?

EDIT: It may be worth noting that I am able to ping the DNS name and the raw IP of the remote location that I am trying to mount.

6
  • superuser.com/questions/430163/cifs-share-mount-errors have you tried everything in this? If not go for that first.
    – alpha
    Commented Jul 18, 2018 at 13:52
  • 1
    @DeclanGallagher I'll check it out right now, thanks Declan. I'll report back if anything in there works for me! Commented Jul 18, 2018 at 13:53
  • 2
    Try mounting via the IP address as opposed to the DNS name Commented Jul 18, 2018 at 14:02
  • @RamanSailopal I have tried this and the error is the same :( Commented Jul 18, 2018 at 14:16
  • 1
    @Buddika that person's problem was with the IP address being wrong. I'm not in that boat. I've tried with the DNS and the IP typed in. It may be worth noting, I can ping the DNS from the RHEL7 machine I'm attempting to mount at. Commented Jul 18, 2018 at 14:22

5 Answers 5

7

The issue ended up being that the route to the NAS was missing. Once the route was added, I was able to mount the drive with ease.

route add-net x.x.x.x netmask x.x.x.x gw x.x.x.x

Hopefully this helps someone else in the future!

3
  • 3
    So you're saying this was a network error? Initially you wrote that you could ping both the IP and the DNS name, how did that work if the routing was wrong?
    – ketil
    Commented Jan 14, 2019 at 16:53
  • @ketil I had to delete my previous response here, to you, after noticing that my Jul 18th 2018 comment clarified that I was indeed able to ping the desired location from the RHEL7 machine I was working with. Commented May 30, 2019 at 13:09
  • Mine was a firewall blocking
    – NickSoft
    Commented Jun 18, 2022 at 1:18
3

I got this error when mounting a remote windows 10 SAMBA drive on ubuntu 18.04. After waiting for 10 minutes and running the same command, it worked normally. Maybe the problem can sometimes be caused by something slow on the server side?

1
  • 1
    I'm running into this, where the mount fail with "mount error(115): Operation now in progress" and then it works the next try
    – Pieter
    Commented Aug 3, 2021 at 20:30
1

Well, I had the same problem after I got windows 10 update 1809. The windows firewall was blocking the access. There is a predefined rule for inbound SMB conections that was not activated for private network.

Funny thing: It seems to be activated for public networks....

3
  • I also had to enable the netlogon service rule in my firewall before I could successfully mount.
    – Indecent
    Commented May 14, 2020 at 12:41
  • This behavior may have been caused by the fact that the query whether the "PC can be found by other devices in this network" has not been answered with "yes". The matching firewall rule has to be activated manually then.
    – ltlBeBoy
    Commented Jun 9, 2020 at 10:39
  • The built-in firewall rule only allows connections on the "Local subnet", so you may have to create an additional firewall rule for TCP port 445, especially if using VPN. Also if using VPN, make sure you set the network profile (e.g. with Set-NetConnectionProfile) on the VPN connection, rather than your internet connection.
    – Fax
    Commented Feb 11, 2021 at 15:06
0

I found solution here: make sure your box is able to resolve the sharing server hostname properly. In my case I had to correct record in /etc/hosts.

0

Just replace the network path with the IP address of sharing device

1

1
  • This worked for me. Somehow //NAS/ wasn't resolving over openVPN
    – Jonathan
    Commented Nov 22, 2022 at 22:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .