0

I am using a fresh Debian 9.5 install with Gnome as my desktop, inside a VirtualBox (with GuestAdditions) running on a Windows 10 system, all on a brand new Lenovo Thinkpad x1 Yoga (with all the bells and whistles!).

This laptop has two pointer interfaces: a trackpad, and a nub.

In order to "scroll" with the nub, you push the "middle mouse button" and "move" the nub up and down. To scroll with the trackpad, you put two fingers on it and go up and down.

Infuriatingly (and this does not happen on my other ThinkPad with Debian installed natively!!), with the "mouse and trackpad" settings' "Natural Scrolling" option set to off, if I put two fingers on the trackpad and move it "north," the content on my screen will "Scroll down" (content at the top of the screen will disappear, content at the bottom will appear). This is horrible and so I immediately switched that option to on. Now, even worse, if I use my nub scroller, pressing the middle mouse button and then moving the nub "south" will cause the content to "scroll up!" (content at the top of the screen will appear). This is horrible!

For the life of me, I can't find a way to independently set these settings. I have a feeling it's something to do with how VirtualBox tells Debian what interfaces are connected because I don't have this issue on my native installation on another Thinkpad. Alternatively, something has changed in the latest iterations of thinkpads.

How can I independently set the "scroll direction" of my nub and my trackpad?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.