0

I have antergos and gnome as DE dual booted with windows 10.

Everything was ok until I powered on the laptop and played a movie, there was no sound.(Also no sound when headphones plugged)

There is sound in windows so its not a hardware issue.

Here are some system details:

System:

$ uname -a
Linux prometheus 4.17.6-1-ARCH #1 SMP PREEMPT Wed Jul 11 19:14:29 UTC 2018 x86_64 GNU/Linux

Card:

$ cat /proc/asound/cards
0 [PCH            ]: HDA-Intel - HDA Intel PCH
                     HDA Intel PCH at 0xef528000 irq 16

Drivers:

$ lsmod | grep snd
snd_hda_codec_hdmi     57344  1
snd_hda_codec_realtek   110592  1
snd_hda_codec_generic    86016  1 snd_hda_codec_realtek
snd_soc_skl           114688  0
snd_soc_skl_ipc        73728  1 snd_soc_skl
snd_hda_ext_core       28672  1 snd_soc_skl
snd_soc_sst_dsp        36864  1 snd_soc_skl_ipc
snd_soc_sst_ipc        16384  1 snd_soc_skl_ipc
snd_soc_acpi           16384  1 snd_soc_skl
snd_soc_core          290816  1 snd_soc_skl
snd_compress           24576  1 snd_soc_core
ac97_bus               16384  1 snd_soc_core
snd_pcm_dmaengine      16384  1 snd_soc_core
snd_hda_intel          45056  3
snd_hda_codec         151552  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
snd_hda_core           94208  7 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_hda_codec_realtek,snd_soc_skl
snd_hwdep              16384  1 snd_hda_codec
snd_pcm               135168  8 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_soc_core,snd_soc_skl,snd_hda_core,snd_pcm_dmaengine
snd_timer              36864  1 snd_pcm
snd                    98304  16 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_compress,snd_soc_core,snd_pcm
soundcore              16384  1 snd

alsamixers output

lspci | grep Audio output:

00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)

aplay -lL output:

null
    Discard all samples (playback) or generate zero samples (capture)
pulse
    PulseAudio Sound Server
default
    Default ALSA Output (currently PulseAudio Sound Server)
sysdefault:CARD=PCH
    HDA Intel PCH, ALC294 Analog
    Default Audio Device
front:CARD=PCH,DEV=0
    HDA Intel PCH, ALC294 Analog
    Front speakers
surround21:CARD=PCH,DEV=0
    HDA Intel PCH, ALC294 Analog
    2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=PCH,DEV=0
    HDA Intel PCH, ALC294 Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=PCH,DEV=0
    HDA Intel PCH, ALC294 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=PCH,DEV=0
    HDA Intel PCH, ALC294 Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=PCH,DEV=0
    HDA Intel PCH, ALC294 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=PCH,DEV=0
    HDA Intel PCH, ALC294 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
hdmi:CARD=PCH,DEV=0
    HDA Intel PCH, HDMI 0
    HDMI Audio Output
hdmi:CARD=PCH,DEV=1
    HDA Intel PCH, HDMI 1
    HDMI Audio Output
hdmi:CARD=PCH,DEV=2
    HDA Intel PCH, HDMI 2
    HDMI Audio Output
hdmi:CARD=PCH,DEV=3
    HDA Intel PCH, HDMI 3
    HDMI Audio Output
hdmi:CARD=PCH,DEV=4
    HDA Intel PCH, HDMI 4
    HDMI Audio Output
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC294 Analog [ALC294 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

System is fully updated and I tried reinstalling pavucontrol pulseaudio pulseaudio-alsa pulseaudio-bluetooth alsa-firmware alsa-lib alsa-utils

Nothing worked :( I like arch linux but it sometimes gets annoying.

  • 3
    Try increase master volume. – Ipor Sircer Jul 17 '18 at 22:33
  • 1
    This used to happen to me as well on older distro, the suggestion of turning up the master vol was always the solution. – slm Jul 18 '18 at 4:28
  • 1
    Also, if you use Pulseaudio and not only ALSA, start pavucontrol while your application is active, and check if it's using the correct output device, and if all volume sliders are high enough, and if none is muted. – dirkt Jul 18 '18 at 6:06
1

Found this page following up post by Manjaro user with same Realtek ALC294
alc294-analog-audio-card-detected-but-no-sound-internaly-or-headphones

Also found this page from ubuntu user indicating cause of problem
no-sound-output-ubuntu-17-10-asus-zenbook-13

All 3 appear to be same problem caused by windows 10 shutdown

Web search results show no other Linux issues reported for ALC294; suggests this audio device working in Linux when not affected by windows

  • I didn't find what the problem is but when I powered off laptop from linux for some hours it just got fixed automatically. – Miladdarren Aug 8 '18 at 9:08
0

I found that this problem is common in windows/linux dual boot systems and the solution for me was putting system into suspend mode by running systemctl suspend in linux system and when you get back everything is ok, sound is working again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.